summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2018-03-21 03:44:55 +0000
committerLudovic Courtès <ludo@gnu.org>2018-03-31 19:27:21 +0200
commitac7cdb40abc50622f8e60cd9891bb8424d739503 (patch)
treeb0cb372e48bb7667bd14009a7a7d5135dc026a31 /gnu/packages/haskell.scm
parentd96a1bfe2bb029ac5cac4bcc07dc06a58ee36699 (diff)
gnu: Add ghc-attoparsec-iso8601.
* gnu/packages/haskell.scm (ghc-attoparsec-iso8601): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index d5052788aa..7909b3e6af 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9029,4 +9029,27 @@ for managing flexibly-sized collections of resources such as database
connections.")
(license license:bsd-3)))
+(define-public ghc-attoparsec-iso8601
+ (package
+ (name "ghc-attoparsec-iso8601")
+ (version "1.0.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "attoparsec-iso8601-" version "/"
+ "attoparsec-iso8601-" version ".tar.gz"))
+ (sha256
+ (base32
+ "12l55b76bhya9q89mfmqmy6sl5v39b6gzrw5rf3f70vkb23nsv5a"))))
+ (build-system haskell-build-system)
+ (inputs `(("ghc-attoparsec" ,ghc-attoparsec)
+ ("ghc-base-compat" ,ghc-base-compat)
+ ("ghc-text" ,ghc-text)))
+ (home-page "https://github.com/bos/aeson")
+ (synopsis "Parse ISO 8601 dates")
+ (description "Haskell library for parsing of ISO 8601 dates, originally
+from aeson.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here