summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2017-10-18 03:07:23 +0000
committerLudovic Courtès <ludo@gnu.org>2017-10-22 15:32:14 -0700
commitbdd7e3950fba9ab2e49c0bc8be015556563bc4ba (patch)
treefd987984c880e28b572f7d0af51d9cb9ce54e84b /gnu/packages/haskell.scm
parentc1274a0b7930bc799710f681a8a0d19d3d7e2ac1 (diff)
gnu: Add ghc-erf.
* gnu/packages/haskell.scm (ghc-erf): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index be6b0893f5..3226325025 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9056,4 +9056,25 @@ deriver for unboxed vectors, given a pair of coercion functions to
and from some existing type with an Unbox instance.")
(license license:bsd-3)))
+(define-public ghc-erf
+ (package
+ (name "ghc-erf")
+ (version "2.0.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "erf-" version "/"
+ "erf-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0dxk2r32ajmmc05vaxcp0yw6vgv4lkbmh8jcshncn98xgsfbgw14"))))
+ (build-system haskell-build-system)
+ (home-page "https://hackage.haskell.org/package/erf")
+ (synopsis "The error function, erf, and related functions for Haskell")
+ (description "This Haskell library provides a type class for the
+error function, erf, and related functions. Instances for Float and
+Double.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here