summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2017-10-18 03:07:46 +0000
committerLudovic Courtès <ludo@gnu.org>2017-10-22 15:32:17 -0700
commitcaac21006d5b5214c66a5254167002048873e917 (patch)
tree9a19b532f9cd958a9458915e05eef89d60f2f007 /gnu/packages/haskell.scm
parent8155778f52896211e869ffb469be01107c0651c7 (diff)
gnu: Add ghc-cryptohash-md5.
* gnu/packages/haskell.scm (ghc-cryptohash-md5): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index a2dc8bf3b6..c064cec555 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9698,4 +9698,30 @@ the MD5 digest (hash) algorithm. This now supports the @code{crypto-api} class
interface.")
(license license:bsd-3)))
+(define-public ghc-cryptohash-md5
+ (package
+ (name "ghc-cryptohash-md5")
+ (version "0.11.100.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "cryptohash-md5-" version "/"
+ "cryptohash-md5-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1y8q7s2bn4gdknw1wjikdnar2b5pgz3nv3220lxrlgpsf23x82vi"))))
+ (build-system haskell-build-system)
+ (arguments
+ `(#:tests? #f)) ; tests require old version of ghc-hunit (0.9)
+ (native-inputs `(("ghc-base16-bytestring" ,ghc-base16-bytestring)
+ ("ghc-puremd5" ,ghc-puremd5)
+ ("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)
+ ("ghc-hunit" ,ghc-hunit)))
+ (home-page "https://github.com/hvr/cryptohash-md5")
+ (synopsis "MD5 implementation for Haskell")
+ (description "This Haskell package provides implementation of MD5.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here