summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorTonton <tonton@riseup.net>2018-05-17 21:34:37 +0200
committerLudovic Courtès <ludo@gnu.org>2018-05-20 22:58:50 +0200
commitdea5c0b8d0d82bcd27f2b25953739fb2e0a442cc (patch)
tree4c26bbe8e2fc73c1975cdae09b55cb1d67932938 /gnu/packages/haskell.scm
parent6c4ae1733430f976d6b5b95c5b18919944f949f3 (diff)
gnu: Add ghc-bytes.
* gnu/packages/haskell.scm (ghc-bytes): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 874a9202a3..c8fade065d 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9483,4 +9483,37 @@ address string against RFC 5322.")
(inputs `(("ghc-unordered-containers" ,ghc-unordered-containers)
,@(package-inputs ghc-semigroupoids)))))
+(define-public ghc-bytes
+ (package
+ (name "ghc-bytes")
+ (version "0.15.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://hackage.haskell.org/package/bytes-"
+ version "/bytes-"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "121x3iqlm8pghw8cd9g30cnqbl7jrdpfjxdanmqdqllajw6xivrm"))))
+ (build-system haskell-build-system)
+ (inputs `(("ghc-cereal" ,ghc-cereal)
+ ("cabal-doctest" ,cabal-doctest)
+ ("ghc-doctest" ,ghc-doctest-0.13)
+ ("ghc-mtl" ,ghc-mtl)
+ ("ghc-scientific" ,ghc-scientific)
+ ("ghc-text" ,ghc-text)
+ ("ghc-transformers-compat" ,ghc-transformers-compat)
+ ("ghc-unordered-containers" ,ghc-unordered-containers)
+ ("ghc-void" ,ghc-void)
+ ("ghc-vector" ,ghc-vector)))
+ (synopsis "Serialization between @code{binary} and @code{cereal}")
+ (description "This package provides a simple compatibility shim that lets
+you work with both @code{binary} and @code{cereal} with one chunk of
+serialization code.")
+ (home-page "https://hackage.haskell.org/package/bytes")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here