summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-17 18:39:45 +0200
committerMarius Bakke <marius@gnu.org>2022-09-18 10:35:37 +0200
commit29e4955d0db8d39e1d38c47543766a95f05ebae2 (patch)
tree4d725b39fcfd8faa19bf383b0a431bf223a0111a /gnu/packages/haskell.scm
parent4ac042ccedfc90cd167f23ea07251480cba022e0 (diff)
gnu: ghc@8.4: Adjust test suite for Python 3.10.
This applies the substitution added in 48718135e74994e671eaf6dc6b74ac90e1e8a939 also for GHC@8.4. Somehow this problem is not fatal there and went unnoticed. * gnu/packages/haskell.scm (ghc-8.4)[native-inputs]: Patch the test driver for Python 3.10 compatibility.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index ed2eaea984..036d63655e 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -701,7 +701,13 @@ interactive environment for the functional language Haskell.")
version "/" name "-" version "-testsuite.tar.xz"))
(sha256
(base32
- "0s8lf9sxj7n89pjagi58b3fahnp34qvmwhnn0j1fbg6955vbrfj6"))))))
+ "0s8lf9sxj7n89pjagi58b3fahnp34qvmwhnn0j1fbg6955vbrfj6"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; collections.Iterable was moved to collections.abc in Python 3.10.
+ '(substitute* "testsuite/driver/testlib.py"
+ (("collections\\.Iterable")
+ "collections.abc.Iterable")))))))
(arguments
(substitute-keyword-arguments (package-arguments ghc-8.0)
((#:phases phases)