summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 21:13:05 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 23:37:04 -0400
commite244ea2445bcda466b7ef2fc82205472e4454b80 (patch)
treea7435f1c22c00bba6a19b785c6dccbafbe05479f /gnu/packages/haskell.scm
parente6090152a686b95b2bd2f95f7b94205f049e5754 (diff)
gnu: ghc-9.2: Make the skip-T21694-i686 phase unconditional.
* gnu/packages/haskell.scm (ghc-9.2) [arguments]: Remove match conditional for the skip-T21694-i686 phase.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm29
1 files changed, 13 insertions, 16 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index c6d301c76c..1d8b05bc8a 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
+;;; Copyright © 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1325,20 +1326,16 @@ interactive environment for the functional language Haskell.")
(substitute-keyword-arguments (package-arguments base)
((#:phases phases '%standard-phases)
#~(modify-phases #$phases
- ;; File Common.hs has been moved to src/ in this release.
- (replace 'fix-cc-reference
- (lambda _
- (substitute* "utils/hsc2hs/src/Common.hs"
- (("\"cc\"") "\"gcc\""))))
- ;; FIXME: Remove i686-specific match on the next rebuild cycle.
- #$@(match (%current-system)
- ("i686-linux"
- #~((add-after 'skip-more-tests 'skip-T21694-i686
- (lambda _
- (substitute* '("testsuite/tests/simplCore/should_compile/all.T")
- (("^test\\('T21694', \\[ " all)
- (string-append all "when(arch('i386'), skip), ")))))))
- (_ #~()))))
+ ;; File Common.hs has been moved to src/ in this release.
+ (replace 'fix-cc-reference
+ (lambda _
+ (substitute* "utils/hsc2hs/src/Common.hs"
+ (("\"cc\"") "\"gcc\""))))
+ (add-after 'skip-more-tests 'skip-T21694-i686
+ (lambda _
+ (substitute* '("testsuite/tests/simplCore/should_compile/all.T")
+ (("^test\\('T21694', \\[ " all)
+ (string-append all "when(arch('i386'), skip), ")))))))
;; Increase verbosity, so running the test suite does not time out on CI.
((#:make-flags make-flags ''())
#~(cons "VERBOSE=4" #$make-flags))))
@@ -1350,8 +1347,8 @@ interactive environment for the functional language Haskell.")
,(origin
(method url-fetch)
(uri (string-append
- "https://www.haskell.org/ghc/dist/"
- version "/ghc-" version "-testsuite.tar.xz"))
+ "https://www.haskell.org/ghc/dist/"
+ version "/ghc-" version "-testsuite.tar.xz"))
(sha256
(base32
"19ha0hidrijawy53vm2r0sgml5zkl8126mqy7p0pyacmw3k7913l"))