summaryrefslogtreecommitdiff
path: root/gnu/packages/hurd.scm
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2024-01-19 12:32:46 +0100
committerJanneke Nieuwenhuizen <janneke@gnu.org>2024-01-19 12:58:11 +0100
commit2dd16f46766997c0b3e4ee973ce6e792a4d84fcb (patch)
tree8acea2b8a827c9392d885cf35dbcc3bfc1619d71 /gnu/packages/hurd.scm
parentd42ca92d226419f8eae852f49bf686229d7c1a9c (diff)
gnu: hurd: Add gnumach-headers as native input.
This provides the include/mach/machine/mach_i386.h. * gnu/packages/hurd.scm (hurd)[native-inputs]: Add gnumach-headers, or gnumach-headers-cross when cross-building. [arguments]: Remove #t from phases. Change-Id: Id57e0cf184c7793be52192bdc5587c6e6ef2a312
Diffstat (limited to 'gnu/packages/hurd.scm')
-rw-r--r--gnu/packages/hurd.scm33
1 files changed, 17 insertions, 16 deletions
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 4a1101d965..376cf426fc 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -353,8 +353,7 @@ Hurd-minimal package which are needed for both glibc and GCC.")
"include/tirpc")
":" (or (getenv var) ""))))
'("CROSS_C_INCLUDE_PATH" "C_INCLUDE_PATH"
- "CROSS_CPATH" "CPATH"))
- #t))
+ "CROSS_CPATH" "CPATH"))))
(add-after 'unpack 'fix-rpc-headers
(lambda _
(substitute* "nfs/mount.c"
@@ -367,14 +366,12 @@ Hurd-minimal package which are needed for both glibc and GCC.")
"nfsd/main.c"
"nfsd/ops.c")
(("#include <rpc/pmap_prot.h>" m)
- (string-append "#include <rpc/types.h>\n#include <rpc/xdr.h>\n" m)))
- #t))
+ (string-append "#include <rpc/types.h>\n#include <rpc/xdr.h>\n" m)))))
(add-before 'build 'pre-build
(lambda _
;; Don't change the ownership of any file at this time.
(substitute* '("daemons/Makefile" "utils/Makefile")
- (("-o root -m 4755") ""))
- #t))
+ (("-o root -m 4755") ""))))
(add-after 'unpack 'create-runsystem
(lambda _
;; XXX Work towards having startup.c invoke the Guile rc
@@ -449,8 +446,7 @@ exec ${system}/rc \"$@\"
":" util-linux "/sbin\n"))
(("/sbin/") (string-append out "/sbin/"))
(("/libexec/") (string-append out "/libexec/"))
- (("/hurd/") (string-append out "/hurd/")))
- #t)))
+ (("/hurd/") (string-append out "/hurd/"))))))
(add-after 'patch-shebangs 'patch-libexec-shebangs
(lambda* (#:key inputs outputs #:allow-other-keys)
;; XXX: Since the 'patch-shebangs' phase doesn't traverse
@@ -460,8 +456,7 @@ exec ${system}/rc \"$@\"
(path (list (string-append bash "/bin"))))
(for-each (lambda (file)
(patch-shebang file path))
- (find-files (string-append out "/libexec")))
- #t)))
+ (find-files (string-append out "/libexec"))))))
(add-after 'build 'build-libdde-linux
(lambda* (#:key inputs native-inputs #:allow-other-keys)
(invoke (string-append (assoc-ref (or native-inputs inputs) "make")
@@ -501,8 +496,7 @@ exec ${system}/rc \"$@\"
(invoke "gunzip" "unifont.gz")
(mkdir-p datadir)
(copy-file "unifont"
- (string-append datadir "/vga-system.bdf"))
- #t))))
+ (string-append datadir "/vga-system.bdf"))))))
#:configure-flags
,#~(list (string-append "LDFLAGS=-Wl,-rpath="
#$output "/lib")
@@ -517,7 +511,11 @@ exec ${system}/rc \"$@\"
"CFLAGS=-fcommon")))
(build-system gnu-build-system)
(inputs
- `(("libgcrypt" ,libgcrypt) ;for /hurd/random
+ `(("gnumach-headers" ,(if (%current-target-system)
+ (cross-gnumach-headers (%current-target-system))
+ gnumach-headers))
+
+ ("libgcrypt" ,libgcrypt) ;for /hurd/random
("libdaemon" ,libdaemon) ;for /bin/console --daemonize
("unifont" ,unifont)
("libpciaccess" ,libpciaccess-0.17) ;need libpciaccess > 0.16
@@ -536,10 +534,13 @@ exec ${system}/rc \"$@\"
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
+ ("gnumach-headers" ,(if (%current-target-system)
+ (cross-gnumach-headers (%current-target-system))
+ gnumach-headers))
("libgcrypt" ,libgcrypt) ;for 'libgcrypt-config'
- ("mig" , (if (%current-target-system)
- (cross-mig (%current-target-system))
- mig))
+ ("mig" ,(if (%current-target-system)
+ (cross-mig (%current-target-system))
+ mig))
("pkg-config" ,pkg-config)
("perl" ,perl)
("texinfo" ,texinfo-4)