summaryrefslogtreecommitdiff
path: root/gnu/packages/hurd.scm
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2023-05-22 11:04:17 +0200
committerJanneke Nieuwenhuizen <janneke@gnu.org>2023-07-19 07:33:55 +0200
commit72dbad505abcf360e2fedb747aad2ad7f4a0c326 (patch)
tree84758beaa08f26508fca8bc47546714fd9e4292b /gnu/packages/hurd.scm
parentc1840e9442f7e69fa864553346e3af1c4c4f5ada (diff)
gnu: mig: Use git-fetch.
Now that we have `git-fetch-from-tarball' to break the cycle in commencement for git-fetch sources, we can finally update mig to use git-fetch to allow `--with-commit' builds. * gnu/packages/hurd.scm (mig)[source]: Use git-fetch again. * gnu/packages/commencement.scm (mig-boot0)[source]: Use git-fetch-from-tarball accordingly.
Diffstat (limited to 'gnu/packages/hurd.scm')
-rw-r--r--gnu/packages/hurd.scm17
1 files changed, 7 insertions, 10 deletions
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index b184657fb9..4064a9e2e8 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -93,21 +93,18 @@
(name "mig")
(version "1.8+git20230520")
(source (origin
- (method url-fetch)
- ;; XXX: Versions 2.35 and 2.37 of glibc can only be built with an
- ;; unreleased version of MiG:
- ;; <https://lists.gnu.org/archive/html/bug-hurd/2023-03/msg00025.html>.
- ;; It cannot be fetched from Git though, as the extra dependency
- ;; on Autoconf/Automake would complicate bootstrapping.
- (uri (string-append "mirror://gnu/guix/mirror/mig-"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.savannah.gnu.org/git/hurd/mig.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1ap31jd9jkvvz3vb88hg19cyqmqzmra724yl1xhcrv7gcgnan7d9"))))
+ "10r0fdjqjzqsy6ajb21rifvhw0wpjvrw6a1zdyliqlzqny5k0qlz"))))
(build-system gnu-build-system)
;; Flex is needed both at build and run time.
(inputs (list gnumach-headers flex))
- (native-inputs (list flex bison))
+ (native-inputs (list autoconf automake flex bison))
(arguments
(list #:tests? #f
#:phases