summaryrefslogtreecommitdiff
path: root/gnu/packages/hurd.scm
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2024-01-21 19:40:43 +0100
committerJanneke Nieuwenhuizen <janneke@gnu.org>2024-01-22 09:42:40 +0100
commitc569d2b3dff815157860f1b812b7c41e2f9ec9a3 (patch)
treeb847abf9e065de6caa794b3f9195a90d4f1a5d39 /gnu/packages/hurd.scm
parent7c60d1e14f4c7f1c20bcf9a6503d906d06d9a6d3 (diff)
gnu: gnumach: Fix build for i686-linux.
* gnu/packages/patches/gnumach-fix-i686-linux-build.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/hurd.scm (gnumach)[source]: Use it. [arguments]: Remove #:make-flags to avoid overriding now-essential CFLAGS set by configure. Rewrite to use gexps. [supported-systems]: Add i686-linux. Change-Id: Ibec03121f90b30160725c87e999e38f677b2e369
Diffstat (limited to 'gnu/packages/hurd.scm')
-rw-r--r--gnu/packages/hurd.scm24
1 files changed, 11 insertions, 13 deletions
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 1d3a0eadfa..2cfd8f998f 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -255,26 +255,24 @@ Hurd-minimal package which are needed for both glibc and GCC.")
(inherit (package-source gnumach-headers))
(patches
(append
- (search-patches "gnumach-support-noide.patch")
+ (search-patches "gnumach-support-noide.patch"
+ "gnumach-fix-i686-linux-build.patch")
(origin-patches (package-source gnumach-headers))))))
(arguments
(substitute-keyword-arguments (package-arguments gnumach-headers)
- ((#:make-flags flags ''())
- `(cons "CFLAGS=-fcommon" ,flags))
((#:configure-flags flags ''())
- `(cons* "--enable-kdb" ;enable kernel debugger
+ `(cons* "--enable-kdb" ;enable kernel debugger
"--disable-net-group"
"--disable-pcmcia-group"
"--disable-wireless-group"
- ,flags))
+ ,flags))
((#:phases phases '%standard-phases)
- `(modify-phases %standard-phases
- (add-after 'install 'produce-image
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (boot (string-append out "/boot")))
- (invoke "make" "gnumach.gz")
- (install-file "gnumach.gz" boot))))))))
+ #~(modify-phases %standard-phases
+ (add-after 'install 'produce-image
+ (lambda _
+ (let ((boot (string-append #$output "/boot")))
+ (invoke "make" "gnumach.gz")
+ (install-file "gnumach.gz" boot))))))))
(native-inputs
(list autoconf
automake
@@ -283,7 +281,7 @@ Hurd-minimal package which are needed for both glibc and GCC.")
mig)
perl
texinfo-4))
- (supported-systems %hurd-systems)
+ (supported-systems `("i686-linux" ,@%hurd-systems))
(synopsis "Microkernel of the GNU system")
(description
"GNU Mach is the microkernel upon which a GNU Hurd system is based.")))