summaryrefslogtreecommitdiff
path: root/gnu/packages/hurd.scm
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2023-03-20 23:10:42 +0100
committerLudovic Courtès <ludo@gnu.org>2023-03-30 12:44:19 +0200
commitc78fd5a25d6ee627905144b2d1ecde7a09e35e43 (patch)
treef08cb0f4b775ab9c5f554c54772fea855778272d /gnu/packages/hurd.scm
parent5661f75d4981544ebb99dc54df6e5cc9d3d7bb98 (diff)
gnu: mig: Update to 1.8+git20220827.
* gnu/packages/hurd.scm (mig): Do it. * gnu/packages/patches/mig-cpu.h-generation.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/hurd.scm')
-rw-r--r--gnu/packages/hurd.scm23
1 files changed, 14 insertions, 9 deletions
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 7f02e6141d..ae764162ff 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -111,15 +111,20 @@ GNU/Hurd."
(define-public mig
(package
(name "mig")
- (version "1.8")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/mig/mig-"
- version ".tar.gz"))
- (sha256
- (base32
- "1gyda8sq6b379nx01hkpbd85lz39irdvz2b9wbr63gicicx8i706"))))
+ (version "1.8+git20220827")
+ (source (origin
+ (method url-fetch)
+ ;; XXX: Version 2.35 of glibc can only be built with an
+ ;; unreleased version of MiG:
+ ;; <https://lists.gnu.org/archive/html/bug-hurd/2023-03/msg00025.html>.
+ ;; It cannot be fetched from Git though, as the extra dependency
+ ;; on Autoconf/Automake would complicate bootstrapping.
+ (uri (string-append "mirror://gnu/guix/mirror/mig-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "163d37s9lscd6zxyfng421m9nl857464mgjj90xsrcl5ykbng5p2"))
+ (patches (search-patches "mig-cpu.h-generation.patch"))))
(build-system gnu-build-system)
;; Flex is needed both at build and run time.
(inputs (list gnumach-headers flex))