summaryrefslogtreecommitdiff
path: root/gnu/packages/hurd.scm
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2023-06-20 17:09:17 +0200
committerJanneke Nieuwenhuizen <janneke@gnu.org>2023-07-20 10:11:37 +0200
commit6547d3852b11966271535962110d9e68f50c95fc (patch)
tree84d9a173683cb1be6dc4ea21038ce820d1315a57 /gnu/packages/hurd.scm
parentc4c08775a820868059b59c68d4dfd6be0c9d9010 (diff)
gnu: hurd: Support native build on the Hurd.
* gnu/packages/hurd.scm (hurd)[arguments]: In phases 'build-libdde-linux' and 'install-goodies', also look in inputs for dependencies. There is no check target, so set #:tests? to #false.
Diffstat (limited to 'gnu/packages/hurd.scm')
-rw-r--r--gnu/packages/hurd.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 4064a9e2e8..f697694124 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -329,14 +329,14 @@ Hurd-minimal package which are needed for both glibc and GCC.")
"hurd-rumpdisk-no-hd.patch"))))
(version (package-version hurd-headers))
(arguments
- `(#:phases
+ `(#:tests? #f ;no "check" target
+ #:phases
(modify-phases %standard-phases
(add-after 'unpack 'prepare-addons
(lambda* (#:key native-inputs inputs #:allow-other-keys)
;; First we import the things we want from dde.
(for-each make-file-writable (find-files "."))
- (let ((dde (or (assoc-ref inputs "dde-sources")
- (assoc-ref native-inputs "dde-sources"))))
+ (let ((dde (assoc-ref (or native-inputs inputs) "dde-sources")))
(for-each (lambda (dir)
(copy-recursively
(string-append dde "/" dir ) dir))
@@ -466,13 +466,13 @@ exec ${system}/rc \"$@\"
#t)))
(add-after 'build 'build-libdde-linux
(lambda* (#:key inputs native-inputs #:allow-other-keys)
- (invoke (string-append (assoc-ref native-inputs "make")
+ (invoke (string-append (assoc-ref (or native-inputs inputs) "make")
"/bin/make")
;; XXX There can be a race condition because subdirs
;; aren't interdependent targets in the Makefile.
"-j1" "-C" "libdde_linux26"
(string-append "SHELL="
- (assoc-ref native-inputs "bash")
+ (assoc-ref (or native-inputs inputs) "bash")
"/bin/bash")
(string-append "CC="
,(cc-for-target)))))
@@ -483,12 +483,12 @@ exec ${system}/rc \"$@\"
(let* ((out (assoc-ref outputs "out"))
(datadir (string-append out "/share/hurd")))
;; Install libdde_linux26.
- (invoke (string-append (assoc-ref native-inputs "make")
+ (invoke (string-append (assoc-ref (or native-inputs inputs) "make")
"/bin/make")
"-C" "libdde_linux26" "install"
(string-append "SHELL="
- (assoc-ref native-inputs "bash")
- "/bin/bash")
+ (assoc-ref (or native-inputs inputs) "bash")
+ "/bin/bash")
(string-append "INSTALLDIR="
out
"/share/libdde_linux26/build/include"))
@@ -590,8 +590,7 @@ implementing them.")
(add-after 'unpack 'prepare-dde
(lambda* (#:key native-inputs inputs #:allow-other-keys)
(for-each make-file-writable (find-files "."))
- (let ((dde (or (assoc-ref inputs "dde-sources")
- (assoc-ref native-inputs "dde-sources"))))
+ (let ((dde (assoc-ref (or native-inputs inputs) "dde-sources")))
(for-each (lambda (dir)
(copy-recursively
(string-append dde "/" dir ) dir))