summaryrefslogtreecommitdiff
path: root/gnu/packages/hurd.scm
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2023-05-22 11:04:14 +0200
committerJosselin Poiret <dev@jpoiret.xyz>2023-07-13 18:20:04 +0200
commit0613df90ddadce62b2c6e22048b216602bd9a230 (patch)
tree5a5992e47c8be528905750eeb4bc809e0d122045 /gnu/packages/hurd.scm
parentc2bb342b5ff0ac15d6dc37a9ba8daeb8956237e1 (diff)
gnu: hurd: Update supported systems.
* gnu/packages/hurd.scm (gnumach-headers, hurd-headers, hurd-minimal, hurd-core-headers, gnumach): Update supported systems to %hurd-systems.
Diffstat (limited to 'gnu/packages/hurd.scm')
-rw-r--r--gnu/packages/hurd.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 438f07c20c..8ca8415436 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -79,6 +79,7 @@
#:tests? #f))
(native-inputs
(list autoconf automake texinfo-4))
+ (supported-systems %hurd-systems)
(home-page "https://www.gnu.org/software/hurd/microkernel/mach/gnumach.html")
(synopsis "GNU Mach kernel headers")
(description
@@ -189,6 +190,7 @@ communication.")
"ac_cv_func_file_futimens=no")
#:tests? #f))
+ (supported-systems %hurd-systems)
(home-page "https://www.gnu.org/software/hurd/hurd.html")
(synopsis "GNU Hurd headers")
(description
@@ -224,6 +226,7 @@ Library and other user programs.")
;; Build libihash.
(invoke "make" "-Clibihash" "libihash.a")))))))
+ (supported-systems %hurd-systems)
(home-page "https://www.gnu.org/software/hurd/hurd.html")
(synopsis "GNU Hurd libraries")
(description
@@ -256,6 +259,7 @@ Library for GNU/Hurd.")
directories)
#t))))))
(inputs (list gnumach-headers hurd-headers hurd-minimal))
+ (supported-systems %hurd-systems)
(synopsis "Union of the Hurd headers and libraries")
(description
"This package contains the union of the Mach and Hurd headers and the
@@ -291,7 +295,7 @@ Hurd-minimal package which are needed for both glibc and GCC.")
mig)
perl
texinfo-4))
- (supported-systems (cons "i686-linux" %hurd-systems))
+ (supported-systems %hurd-systems)
(synopsis "Microkernel of the GNU system")
(description
"GNU Mach is the microkernel upon which a GNU Hurd system is based.")))