summaryrefslogtreecommitdiff
path: root/gnu/packages/image-viewers.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-21 23:35:12 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-28 22:23:04 -0400
commite05de22479ddc0775377464bd0ef4f1e946c75ce (patch)
treed0fbcca10afd2071d54c6b91748ab48bb993f2d6 /gnu/packages/image-viewers.scm
parentf215d801277a60cc1d862ed59c179cb8a482ced5 (diff)
gnu: geeqie: Update to 2.0.1.
* gnu/packages/image-viewers.scm (geeqie): Update to 2.0.1. [build-system]: Switch to meson. [arguments]: Delete field. [inputs]: Remove clutter. [native-inputs]: Add xxd. Remove autoconf and automake. * gnu/packages/patches/geeqie-clutter.patch: Delete file. * gnu/local.mk (dist_patch_DATA): De-register it.
Diffstat (limited to 'gnu/packages/image-viewers.scm')
-rw-r--r--gnu/packages/image-viewers.scm48
1 files changed, 13 insertions, 35 deletions
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index 0758cf5b27..470ae08a9b 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -24,7 +24,7 @@
;;; Copyright © 2021 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2021 dissent <disseminatedissent@protonmail.com>
;;; Copyright © 2022 Michael Rohleder <mike@rohleder.de>
-;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Tomasz Jeneralczyk <tj@schwi.pl>
;;; Copyright © 2022 Cairn <cairn@pm.me>
;;;
@@ -101,6 +101,7 @@
#:use-module (gnu packages upnp)
#:use-module (gnu packages version-control)
#:use-module (gnu packages video)
+ #:use-module (gnu packages vim)
#:use-module (gnu packages web)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages xml)
@@ -231,7 +232,7 @@ actions.")
(define-public geeqie
(package
(name "geeqie")
- (version "1.6")
+ (version "2.0.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -239,43 +240,20 @@ actions.")
(commit (string-append "v" version))))
(sha256
(base32
- "1i9yd8lddp6b9s9vjjjzbpqj4bvwidxc6kiba6vdrk7dda5akyky"))
- (file-name (git-file-name name version))
- (patches (search-patches "geeqie-clutter.patch"))))
- (build-system gnu-build-system)
- (arguments
- ;; Enable support for a "map" pane using GPS data.
- `(#:configure-flags '("CFLAGS=-O2 -g -fcommon"
- "--enable-map"
- "--enable-gtk3")
- #:phases (modify-phases %standard-phases
- (add-after 'unpack 'correctly-locate-aux-scripts
- ;; The git checkout has symlinks under the auxdir
- ;; directory pointing to /usr/share/automake-1.16/depcomp
- ;; and /usr/share/automake-1.16/install-sh, which causes
- ;; the configure phase to fail (see:
- ;; https://github.com/BestImageViewer/geeqie/issues/936).
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((automake (assoc-ref inputs "automake")))
- (delete-file "auxdir/depcomp")
- (symlink (car (find-files automake "depcomp"))
- "auxdir/depcomp")
- (delete-file "auxdir/install-sh")
- (symlink (car (find-files automake "install-sh"))
- "auxdir/install-sh")))))))
+ "199s0f3khnycr5vhk2ww3xnnasz7dzwxdl89pxjadq6rpgprfqyh"))
+ (file-name (git-file-name name version))))
+ (build-system meson-build-system)
(inputs
- (list clutter
- libchamplain
+ (list exiv2
+ gtk+
lcms
- exiv2
- libpng
- gtk+))
+ libchamplain
+ libpng))
(native-inputs
- (list autoconf
- automake
- `(,glib "bin") ; glib-gettextize
+ (list `(,glib "bin") ; glib-gettextize
intltool
- pkg-config))
+ pkg-config
+ xxd))
(home-page "https://www.geeqie.org/")
(synopsis "Lightweight GTK+ based image viewer")
(description