summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-01-22 01:00:19 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2023-01-29 01:00:01 +0100
commit0d036019318ccef0ce56270b60ef5074ed9d0400 (patch)
tree44ff83847b99a825963046cfba85ee9c74cf7f77 /gnu/packages/image.scm
parent5618153e7346e838f20a4e5c042d97eb9ad57314 (diff)
gnu: phockup: Test exiftool patching.
* gnu/packages/image.scm (phockup)[arguments]: Unset PATH during tests.
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 0b57d88468..87a9b791bc 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -2434,7 +2434,12 @@ Wacom-style graphics tablets.")
(string-append "'" (search-input-file inputs "bin/exiftool"))))))
(add-before 'install 'check
(lambda _
- (invoke "pytest")))
+ ;; Test without PATH to make sure ‘exiftool’ is properly found.
+ (let ((path (getenv "PATH"))
+ (pytest (which "pytest")))
+ (setenv "PATH" "")
+ (invoke pytest)
+ (setenv "PATH" path))))
(add-after 'install 'install-bin
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))