summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-01-22 01:00:03 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2023-01-29 01:00:01 +0100
commit2cea54ba62eaafc92f963299eef54b4f981b2f53 (patch)
tree9cf63a875975454761dd511a553f09433056ecb5 /gnu/packages/image.scm
parente68b0596861fb4695f9bc6d14e84fd82934a9906 (diff)
gnu: libpng-apng: Update to 1.6.39.
I've tweaked the comment, as it made me read an entire e-mail thread only to realise I needn't have done so. * gnu/packages/image.scm (libpng-apng): Update to 1.6.39.
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 704b15cc97..91d68fa0f8 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -178,12 +178,11 @@ library. It supports almost all PNG features and is extensible.")
(license license:zlib)
(home-page "http://www.libpng.org/pub/png/libpng.html")))
-;; libpng-apng should be updated when the APNG patch is released:
-;; <https://bugs.gnu.org/27556>
(define-public libpng-apng
+ ;; The APNG patch is maintained separately and may lag behind upstream libpng.
(package
(name "libpng-apng")
- (version "1.6.37")
+ (version "1.6.39")
(source
(origin
(method url-fetch)
@@ -196,8 +195,7 @@ library. It supports almost all PNG features and is extensible.")
"ftp://ftp.simplesystems.org/pub/libpng/png/src/history"
"/libpng16/libpng-" version ".tar.xz")))
(sha256
- (base32
- "1jl8in381z0128vgxnvn33nln6hzckl7l7j9nqvkaf1m9n1p0pjh"))))
+ (base32 "0dv90dxvmqpk7mbywyjbz8lh08cv4b0ksqp1y62mzvmlf379cihz"))))
(build-system gnu-build-system)
(arguments
`(#:modules ((guix build gnu-build-system)
@@ -231,7 +229,7 @@ library. It supports almost all PNG features and is extensible.")
version "/libpng-" version "-apng.patch.gz"))
(sha256
(base32
- "1dh0250mw9b2hx7cdmnb2blk7ddl49n6vx8zz7jdmiwxy38v4fw2"))))))
+ "1z8cx011a2c7vagwgi92rbmky1wi8awmrdldqh9f5k80pbmbdi2a"))))))
(native-inputs
(list libtool))
;; libpng.la says "-lz", so propagate it.