summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorBruno Victal <mirai@makinata.eu>2022-12-17 00:51:28 +0000
committerLeo Famulari <leo@famulari.name>2023-01-03 12:53:26 -0500
commitfaeeb302c25754b8be5d5f0621e4e4ef20a35812 (patch)
treecbb79fc4ec6b7e4ac12ffe713b8c4813cf4fbe5f /gnu/packages/image.scm
parent2f0418cd2c33497130e1b764952e8063117d7f8a (diff)
gnu: libavif: Rewrite using G-Exps.
* gnu/packages/image.scm (libavif)[arguments]: Rewrite using G-Expressions. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm50
1 files changed, 25 insertions, 25 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index bc1f25627b..80872b1466 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -2168,32 +2168,32 @@ This package can be used to create @code{favicon.ico} files for web sites.")
"1yxmgjlxm1srm98zyj79bj8r8vmg67daqnq0ggcvxknq54plkznk"))))
(build-system cmake-build-system)
(arguments
- `(#:configure-flags '("-DAVIF_CODEC_AOM=ON" "-DAVIF_CODEC_DAV1D=ON"
- ,@(if (string-prefix? "x86_64"
- (or (%current-target-system)
- (%current-system)))
- '("-DAVIF_CODEC_RAV1E=ON")
- '())
- "-DAVIF_BUILD_TESTS=ON")
- #:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda _
- (invoke "./aviftest" "../source/tests/data")))
- (add-after 'install 'install-readme
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (doc (string-append out "/share/doc/libavif-" ,version)))
- (install-file "../source/README.md" doc)))))))
+ (list
+ #:configure-flags
+ #~(list "-DAVIF_CODEC_AOM=ON" "-DAVIF_CODEC_DAV1D=ON"
+ #$@(if (string-prefix? "x86_64"
+ (or (%current-target-system)
+ (%current-system)))
+ '("-DAVIF_CODEC_RAV1E=ON")
+ '())
+ "-DAVIF_BUILD_TESTS=ON")
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "./aviftest" "../source/tests/data")))
+ (add-after 'install 'install-readme
+ (lambda _
+ (let ((doc (string-append #$output "/share/doc/libavif-" #$version)))
+ (install-file "../source/README.md" doc)))))))
(inputs
- `(("dav1d" ,dav1d)
- ("libaom" ,libaom)
- ;; XXX: rav1e depends on rust, which currently only works on x86_64.
- ;; See also the related configure flag when changing this.
- ,@(if (string-prefix? "x86_64" (or (%current-target-system)
- (%current-system)))
- `(("rav1e" ,rav1e))
- '())))
+ (append
+ ;; XXX: rav1e depends on rust, which currently only works on x86_64.
+ ;; See also the related configure flag when changing this.
+ (if (string-prefix? "x86_64" (or (%current-target-system)
+ (%current-system)))
+ (list rav1e) '())
+ (list dav1d libaom)))
(synopsis "Encode and decode AVIF files")
(description "Libavif is a C implementation of @acronym{AVIF, the AV1 Image
File Format}. It can encode and decode all YUV formats and bit depths supported