summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorchris <chris@bumblehead.com>2024-02-07 15:49:45 -0800
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-02-22 16:12:22 +0100
commit8f250436172c8d028a1d62ff8b9b5daae73e4f3a (patch)
tree3620428774c2551807a3b3fcc85ee7f83ab263ea /gnu/packages/image.scm
parent8a8540496f66684e5ba0c27fa139237cb8c50ddb (diff)
gnu: Add libsixel.
* gnu/packages/image.scm (libsixel): New variable. Curl is disabled to mitigate CVE-2021-45340 guix lint warns about. Change-Id: I7c8077dd705409ce914ab347115d0b4fddeb37e1 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 1f434667f8..0ff5e9baed 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -38,6 +38,7 @@
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2023-2024 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2023 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2024 chris <chris@bumblehead.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2816,3 +2817,38 @@ Graphics (PNGs), intended as an easy-to-use replacement for @code{libpng}.")
(license license:bsd-2)
;; Supports SSE on x86-64 and NEON on AArch64.
(properties '((tunable? . #t)))))
+
+(define-public libsixel
+ (package
+ (name "libsixel")
+ (version "1.10.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/libsixel/libsixel")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1nny4295ipy4ajcxmmh04c796hcds0y7z7rv3qd17mj70y8j0r2d"))))
+ (build-system meson-build-system)
+ (arguments
+ (list
+ #:build-type "release"
+ #:configure-flags #~(list "--buildtype=plain"
+ "-Dtests=enabled"
+ "-Dlibcurl=disabled"
+ "-Dgdk-pixbuf2=enabled")))
+ (native-inputs (list pkg-config))
+ (inputs (list gdk-pixbuf libjpeg-turbo libpng python))
+ (home-page "https://github.com/libsixel/libsixel")
+ (synopsis
+ "Encoder and decoder implementation for DEC SIXEL graphics")
+ (description
+ "LibSIXEL is a an encoder/decoder implementation for DEC SIXEL graphics,
+and some converter programs. SIXEL is one of image formats for printer and
+terminal imaging introduced by @acronym{DEC, Digital Equipment Corp.}. Its
+data scheme is represented as a terminal-friendly escape sequence. So if you
+want to view a SIXEL image file, all you have to do is @command{cat} it to
+your terminal.")
+ (license license:expat)))