summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-27 00:17:57 +0200
committerMarius Bakke <marius@gnu.org>2022-08-27 00:17:57 +0200
commit1fd262e8d36b4477556ca06b569d39f5604c7176 (patch)
tree5b0c93931c22787df1f56858c827abfd0c2a02f8 /gnu/packages/image.scm
parentc1a4ef98932799adbd278068fa4fdd8c24fff714 (diff)
parent9f7236e3baf0523c53193c1836ed888e63449f50 (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 8771414344..c31688d045 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -33,6 +33,7 @@
;;; Copyright © 2021 Nicolò Balzarotti <nicolo@nixo.xyz>
;;; Copyright © 2021 Alexandr Vityazev <avityazev@posteo.org>
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
+;;; Copyright © 2022 ( <paren@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2444,3 +2445,28 @@ month and day. All files which are not images or videos or those which do not
have creation date information will be placed in a folder called
@file{unknown}.")
(license license:expat)))
+
+(define-public spng
+ (package
+ (name "spng")
+ (version "0.7.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/randy408/libspng")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0src9ii9w9afz2vgridn9r38pa6888myk28x2bjw0ynw5xcd62hs"))))
+ (build-system meson-build-system)
+ (inputs (list zlib))
+ (native-inputs (list libpng))
+ (home-page "https://libspng.org")
+ (synopsis "Simple PNG loading library")
+ (description
+ "@code{libspng} is a simple C library for loading Portable Network
+Graphics (PNGs), intended as an easy-to-use replacement for @code{libpng}.")
+ (license license:bsd-2)
+ ;; Supports SSE on x86-64 and NEON on AArch64.
+ (properties '((tunable? . #t)))))