summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-07-10 15:57:04 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-18 23:10:04 +0200
commit3f03bd372871a95e2ebb50197172f7a95329feed (patch)
tree35438f28bdc782d3f747abfc7cc99f0b02f855f5 /gnu/packages/image.scm
parent08d048a06bf94b7b043b4ae0ef01b67c0241cb01 (diff)
gnu: Add openjpeg-data.
* gnu/packages/image.scm (openjpeg-data): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 2f354974d2..6604ac5359 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -781,6 +781,28 @@ images of initially unknown height.")
(license (list license:isc ; pbmtools/p?m.5
license:gpl2+)))) ; the rest
+(define-public openjpeg-data
+ (package
+ (name "openjpeg-data")
+ (version "2020.05.19")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/uclouvain/openjpeg-data.git")
+ (commit "c5c4a8c")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1jp84gbhw8q5b8mhc322ql9410hjf32w9hg10x4isfa9j59mnncb"))))
+ (build-system copy-build-system)
+ (synopsis "Test files for OpenJPEG")
+ (description "OpenJPEG-Data contains all files required to run the openjpeg
+test suite, including conformance tests (following Rec. ITU-T T.803 | ISO/IEC
+15444-4 procedures), non-regression tests and unit tests.")
+ (home-page "https://github.com/uclouvain/openjpeg-data")
+ (license license:bsd-2)))
+
(define-public openjpeg
(package
(name "openjpeg")