summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-09-04 21:39:59 +0200
committerAndreas Enge <andreas@enge.fr>2015-09-05 17:58:45 +0200
commit45468e364987ba113fcef20e94d621b8dfc8f33f (patch)
treed8eb7e5cce4c7e34bfe44e3ffbeb889d9333de14 /gnu/packages/image.scm
parent21a8fe1bf520027f8e91be41985ea4c300eff554 (diff)
gnu: libtiff: Update to 4.0.5.
* gnu/packages/patches/libtiff-CVE-2012-4564.patch, gnu/packages/patches/libtiff-CVE-2013-1960.patch, gnu/packages/patches/libtiff-CVE-2013-1961.patch, gnu/packages/patches/libtiff-CVE-2013-4231.patch, gnu/packages/patches/libtiff-CVE-2013-4232.patch, gnu/packages/patches/libtiff-CVE-2013-4243.patch, gnu/packages/patches/libtiff-CVE-2013-4244.patch, gnu/packages/patches/libtiff-CVE-2014-8127-pt1.patch, gnu/packages/patches/libtiff-CVE-2014-8127-pt2.patch, gnu/packages/patches/libtiff-CVE-2014-8127-pt3.patch, gnu/packages/patches/libtiff-CVE-2014-8127-pt4.patch, gnu/packages/patches/libtiff-CVE-2014-8128-pt1.patch, gnu/packages/patches/libtiff-CVE-2014-8128-pt2.patch, gnu/packages/patches/libtiff-CVE-2014-8128-pt3.patch, gnu/packages/patches/libtiff-CVE-2014-8128-pt4.patch, gnu/packages/patches/libtiff-CVE-2014-8128-pt5.patch, gnu/packages/patches/libtiff-CVE-2014-8129.patch, gnu/packages/patches/libtiff-CVE-2014-9330.patch, gnu/packages/patches/libtiff-CVE-2014-9655.patch: Delete files. * gnu-system.am (dist_patch_DATA): Unregister the patches. * gnu/packages/image.scm (libtiff): Update to 4.0.5 and drop the patches.
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm23
1 files changed, 2 insertions, 21 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 84f03967a7..d2de92586f 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -106,32 +106,13 @@ image files in PBMPLUS PPM/PGM, GIF, BMP, and Targa file formats.")
(define-public libtiff
(package
(name "libtiff")
- (version "4.0.3")
+ (version "4.0.5")
(source (origin
(method url-fetch)
(uri (string-append "ftp://ftp.remotesensing.org/pub/libtiff/tiff-"
version ".tar.gz"))
(sha256 (base32
- "0wj8d1iwk9vnpax2h29xqc2hwknxg3s0ay2d5pxkg59ihbifn6pa"))
- (patches (map search-patch '("libtiff-CVE-2012-4564.patch"
- "libtiff-CVE-2013-1960.patch"
- "libtiff-CVE-2013-1961.patch"
- "libtiff-CVE-2013-4231.patch"
- "libtiff-CVE-2013-4232.patch"
- "libtiff-CVE-2013-4244.patch"
- "libtiff-CVE-2013-4243.patch"
- "libtiff-CVE-2014-9330.patch"
- "libtiff-CVE-2014-8127-pt1.patch"
- "libtiff-CVE-2014-8127-pt2.patch"
- "libtiff-CVE-2014-8127-pt3.patch"
- "libtiff-CVE-2014-8127-pt4.patch"
- "libtiff-CVE-2014-8128-pt1.patch"
- "libtiff-CVE-2014-8128-pt2.patch"
- "libtiff-CVE-2014-8128-pt3.patch"
- "libtiff-CVE-2014-8129.patch"
- "libtiff-CVE-2014-9655.patch"
- "libtiff-CVE-2014-8128-pt4.patch"
- "libtiff-CVE-2014-8128-pt5.patch")))))
+ "171hgy4mylwmvdm7gp6ffjva81m4j56v3fbqsbfl7avzxn1slpp2"))))
(build-system gnu-build-system)
(inputs `(("zlib" ,zlib)
("libjpeg-8" ,libjpeg-8)))