summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-12-29 13:01:55 -0500
committerLeo Famulari <leo@famulari.name>2016-12-29 13:36:00 -0500
commit322e724bfad9f82149c3f83416234ab19486a229 (patch)
treed6f0a5949e1aa041b2839076b0d6b9af63950ffd /gnu/packages/image.scm
parent8ecc3c6c447765b1f7c15b980f985d1826f48659 (diff)
gnu: libpng: Fix a null pointer dereference [fixes security issue].
* gnu/packages/patches/libpng-fix-null-ptr-dereference.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/image.scm (libpng)[replacement]: New field. (libpng/fixed): New variable.
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 1c500b3341..69eeaed58d 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -64,6 +64,7 @@
(define-public libpng
(package
(name "libpng")
+ (replacement libpng/fixed)
(version "1.6.25")
(source (origin
(method url-fetch)
@@ -88,6 +89,14 @@ library. It supports almost all PNG features and is extensible.")
(license license:zlib)
(home-page "http://www.libpng.org/pub/png/libpng.html")))
+(define libpng/fixed
+ (package
+ (inherit libpng)
+ (source
+ (origin
+ (inherit (package-source libpng))
+ (patches (search-patches "libpng-fix-null-ptr-dereference.patch"))))))
+
(define-public libpng-1.2
(package
(inherit libpng)