summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2016-11-03 13:36:02 -0400
committerKei Kebreau <kei@openmailbox.org>2016-11-03 13:43:23 -0400
commitb81245ccb38dc16d115519dd3166d8bb2c295bb8 (patch)
tree760fa31575c6c4a515c785bdfc765bc0b93734a7 /gnu/packages/image.scm
parente3100110ce9c1861f64a638ffd91fd34e15db77c (diff)
[PATCH] gnu: Add libjxr.
* gnu/packages/image.scm (libjxr): New variable. * gnu/packages/patches/libjxr-fix-function-signature.patch: New file. * gnu/packages/patches/libjxr-fix-typos.patch: New file. * gnu/local.mk (dist_patch_DATA): Register patches.
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm57
1 files changed, 57 insertions, 0 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 3a1209f4b1..6f83fc4be4 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2016 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -129,6 +130,62 @@ image files in PBMPLUS PPM/PGM, GIF, BMP, and Targa file formats.")
(sha256 (base32
"1cz0dy05mgxqdgjf52p54yxpyy95rgl30cnazdrfmw7hfca9n0h0"))))))
+(define-public libjxr
+ (package
+ (name "libjxr")
+ (version "1.1")
+ (source (origin
+ ;; We are using the Debian source because CodePlex does not
+ ;; deliver an easily downloadable tarball.
+ (method url-fetch)
+ (uri (string-append "mirror://debian/pool/main/j/jxrlib/jxrlib_"
+ version ".orig.tar.gz"))
+ (sha256
+ (base32
+ "00w3f3cmjsm3fiaxq5mxskmp5rl3mki8psrf9y8s1vqbg237na67"))
+ (patch-flags '("-p1" "--binary"))
+ (patches (search-patches "libjxr-fix-function-signature.patch"
+ "libjxr-fix-typos.patch"))))
+ (build-system gnu-build-system)
+ (arguments '(#:make-flags '("CC=gcc")
+ #:tests? #f ; no check target
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; no configure script
+ ;; The upstream makefile does not include an install phase.
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (lib (string-append out "/lib"))
+ (include (string-append out "/include/jxrlib")))
+ (for-each (lambda (file)
+ (install-file file include)
+ (delete-file file))
+ (append
+ '("jxrgluelib/JXRGlue.h"
+ "jxrgluelib/JXRMeta.h"
+ "jxrtestlib/JXRTest.h"
+ "image/sys/windowsmediaphoto.h")
+ (find-files "common/include" "\\.h$")))
+ (for-each (lambda (file)
+ (install-file file lib)
+ (delete-file file))
+ (find-files "." "\\.a$"))
+ (for-each (lambda (file)
+ (install-file file bin)
+ (delete-file file))
+ '("JxrDecApp" "JxrEncApp")))
+ #t)))))
+ (synopsis "Implementation of the JPEG XR standard")
+ (description "JPEG XR is an approved ISO/IEC International standard (its
+official designation is ISO/IEC 29199-2). This library is an implementation of that standard.")
+ (license
+ (license:non-copyleft
+ "file://Makefile"
+ "See the header of the Makefile in the distribution."))
+ (home-page "https://jxrlib.codeplex.com/")))
+
(define-public jpegoptim
(package
(name "jpegoptim")