summaryrefslogtreecommitdiff
path: root/gnu/packages/imagemagick.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-10-13 04:57:40 -0400
committerMark H Weaver <mhw@netris.org>2016-10-13 05:49:33 -0400
commit1cc213850a2009d55e137fee990f9743894c76c5 (patch)
tree79c7e24d74aba175838eb6f77176e66a7b2cd52f /gnu/packages/imagemagick.scm
parente98e9f4e8539e24efaebf22fc3db00b7e772618f (diff)
gnu: graphicsmagick: Update to 1.3.25-1-56c8cae [security fixes].
Fixes CVE-2016-7800, CVE-2016-7996, CVE-2016-7997, and several other flaws. * gnu/packages/imagemagick.scm (graphicsmagick): Update to 1.3.25-1-56c8cae. [source]: Change method from 'url-fetch' to 'hg-fetch'. Add 'file-name'.
Diffstat (limited to 'gnu/packages/imagemagick.scm')
-rw-r--r--gnu/packages/imagemagick.scm95
1 files changed, 52 insertions, 43 deletions
diff --git a/gnu/packages/imagemagick.scm b/gnu/packages/imagemagick.scm
index adce8d4d5b..4c3c636b68 100644
--- a/gnu/packages/imagemagick.scm
+++ b/gnu/packages/imagemagick.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2016 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -24,6 +25,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system perl)
#:use-module (guix download)
+ #:use-module (guix hg-download)
#:use-module (guix utils)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages)
@@ -157,48 +159,55 @@ script.")
(license (package-license imagemagick))))
(define-public graphicsmagick
- (package
- (name "graphicsmagick")
- (version "1.3.25")
- (source (origin
- (method url-fetch)
- (uri (string-append "ftp://ftp.graphicsmagick.org/pub/"
- "GraphicsMagick/" (version-major+minor version)
- "/GraphicsMagick-" version ".tar.xz"))
- (sha256
- (base32
- "17xcc7pfcmiwpfr1g8ys5a7bdnvqzka53vg3kkzhwwz0s99gljyn"))))
- (build-system gnu-build-system)
- (arguments
- `(#:configure-flags
- (list "--with-frozenpaths"
- "--enable-shared=yes"
- "--with-x=yes"
- (string-append "--with-gs-font-dir="
- (assoc-ref %build-inputs "gs-fonts")
- "/share/fonts/type1/ghostscript"))))
- (inputs
- `(("graphviz" ,graphviz)
- ("ghostscript" ,ghostscript)
- ("gs-fonts" ,gs-fonts)
- ("lcms" ,lcms)
- ("libx11" ,libx11)
- ("libxml2" ,libxml2)
- ("libtiff" ,libtiff)
- ("libpng" ,libpng)
- ("libjpeg" ,libjpeg)
- ("freetype" ,freetype)
- ("bzip2" ,bzip2)
- ("xz" ,xz)
- ("zlib" ,zlib)))
- (native-inputs
- `(("pkg-config" ,pkg-config)))
- (outputs '("out" ; 13 MiB
- "doc")) ; ~7 MiB
- (home-page "http://www.graphicsmagick.org")
- (synopsis "Create, edit, compose, or convert bitmap images")
- (description
- "GraphicsMagick provides a comprehensive collection of utilities,
+ (let ((changeset "56c8cae") ; 3e01b
+ (revision "1"))
+ (package
+ (name "graphicsmagick")
+ (version (string-append "1.3.25-" revision "." changeset))
+ (source (origin
+ (method hg-fetch)
+ (uri (hg-reference
+ (url "http://hg.code.sf.net/p/graphicsmagick/code")
+ (changeset changeset)))
+ (file-name (string-append name "-" version "-checkout"))
+ ;;(method url-fetch)
+ ;;(uri (string-append "ftp://ftp.graphicsmagick.org/pub/"
+ ;; "GraphicsMagick/" (version-major+minor version)
+ ;; "/GraphicsMagick-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1s9apvkn0kxr6i4i5wlkfw1prja02rgk689n3cf822zc0dkycxdh"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list "--with-frozenpaths"
+ "--enable-shared=yes"
+ "--with-x=yes"
+ (string-append "--with-gs-font-dir="
+ (assoc-ref %build-inputs "gs-fonts")
+ "/share/fonts/type1/ghostscript"))))
+ (inputs
+ `(("graphviz" ,graphviz)
+ ("ghostscript" ,ghostscript)
+ ("gs-fonts" ,gs-fonts)
+ ("lcms" ,lcms)
+ ("libx11" ,libx11)
+ ("libxml2" ,libxml2)
+ ("libtiff" ,libtiff)
+ ("libpng" ,libpng)
+ ("libjpeg" ,libjpeg)
+ ("freetype" ,freetype)
+ ("bzip2" ,bzip2)
+ ("xz" ,xz)
+ ("zlib" ,zlib)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (outputs '("out" ; 13 MiB
+ "doc")) ; ~7 MiB
+ (home-page "http://www.graphicsmagick.org")
+ (synopsis "Create, edit, compose, or convert bitmap images")
+ (description
+ "GraphicsMagick provides a comprehensive collection of utilities,
programming interfaces, and GUIs, to support file format conversion, image
processing, and 2D vector rendering.")
- (license license:expat)))
+ (license license:expat))))