summaryrefslogtreecommitdiff
path: root/gnu/packages/instrumentation.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-02 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-02 02:00:11 +0200
commit5237abd7ce558fe377652da95a6a83fac17c2ea1 (patch)
tree4f5412f87375f6997ec5f8da560b7973f4f4bf10 /gnu/packages/instrumentation.scm
parent34d7eb9721c3621bd0e82a808042c4c8891c10a9 (diff)
gnu: uftrace: Use G-expressions.
* gnu/packages/instrumentation.scm (uftrace)[arguments]: Rewrite as G-expressions.
Diffstat (limited to 'gnu/packages/instrumentation.scm')
-rw-r--r--gnu/packages/instrumentation.scm51
1 files changed, 26 insertions, 25 deletions
diff --git a/gnu/packages/instrumentation.scm b/gnu/packages/instrumentation.scm
index 263c2909f3..4969f52e66 100644
--- a/gnu/packages/instrumentation.scm
+++ b/gnu/packages/instrumentation.scm
@@ -551,31 +551,32 @@ whole-system symbolic access, and can also handle simple tracing jobs.")
(base32 "0gk0hv3rnf5czvazz1prg21rf9qlniz42g5b389n8a29hqj4q6xr"))))
(build-system gnu-build-system)
(arguments
- `(#:make-flags
- (list
- (string-append "CC=" ,(cc-for-target)))
- ;; runtest hang at some point -- probably dues to
- ;; failed socket connection -- but we want to keep the
- ;; unit tests. Change the target to "test" when fixed.
- #:test-target "unittest"
- #:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key outputs target #:allow-other-keys)
- (let ((arch ,(platform-linux-architecture
- (lookup-platform-by-target-or-system
- (or (%current-target-system)
- (%current-system))))))
- (setenv "ARCH"
- (cond
- ((string=? arch "arm64") "aarch64")
- (else arch)))
- (when target
- (setenv "CROSS_COMPILE" (string-append target "-"))))
- (setenv "SHELL" (which "sh"))
- (invoke "./configure"
- (string-append "--prefix="
- (assoc-ref outputs "out"))))))))
+ (list
+ #:make-flags
+ #~(list
+ (string-append "CC=" #$(cc-for-target)))
+ ;; runtest hangs at some point -- probably due to
+ ;; failed socket connection -- but we want to keep the
+ ;; unit tests. Change the target to "test" when fixed.
+ #:test-target "unittest"
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs target #:allow-other-keys)
+ (let ((arch #$(platform-linux-architecture
+ (lookup-platform-by-target-or-system
+ (or (%current-target-system)
+ (%current-system))))))
+ (setenv "ARCH"
+ (cond
+ ((string=? arch "arm64") "aarch64")
+ (else arch)))
+ (when target
+ (setenv "CROSS_COMPILE" (string-append target "-"))))
+ (setenv "SHELL" (which "sh"))
+ (invoke "./configure"
+ (string-append "--prefix="
+ #$output)))))))
(inputs
(list capstone
elfutils