summaryrefslogtreecommitdiff
path: root/gnu/packages/instrumentation.scm
diff options
context:
space:
mode:
authorOlivier Dion <olivier.dion@polymtl.ca>2022-09-16 19:02:39 -0400
committerMathieu Othacehe <othacehe@gnu.org>2022-09-19 09:07:18 +0200
commit021b2dd0ae45e85bcdb4fb4b62a4d17b482bf1b0 (patch)
tree1c9cfff4c39afec82f9ce939b0c2472991373e09 /gnu/packages/instrumentation.scm
parent6e47d9f6f479ceebd3d0540e2bd8448aa19fa9d2 (diff)
gnu: lttng-tools: Update to 2.13.8.
* gnu/packages/instrumentation.scm (lttng-tools): Update to 2.13.8. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/instrumentation.scm')
-rw-r--r--gnu/packages/instrumentation.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/instrumentation.scm b/gnu/packages/instrumentation.scm
index 35d4157d43..c508801c6b 100644
--- a/gnu/packages/instrumentation.scm
+++ b/gnu/packages/instrumentation.scm
@@ -260,20 +260,17 @@ to ring buffers shared with a consumer daemon.")
(define-public lttng-tools
(package
(name "lttng-tools")
- (version "2.13.7")
+ (version "2.13.8")
(source (origin
(method url-fetch)
(uri (string-append "https://lttng.org/files/lttng-tools/"
"lttng-tools-" version ".tar.bz2"))
(sha256
(base32
- "13gh4bvlgbh82h9vb80aw8l1cfmdj3xyvjg30cscz9vqy7l04yni"))))
+ "1h9x6mmqrxrbgivll3g81l7a9f7ggjmcgwr01f9r01r6kdbmksdi"))))
(build-system gnu-build-system)
(arguments
- `( ;; FIXME - Currently there's a segmentation fault by swig when enabling
- ;; Python's bindings. Thus, bindings are disable here. Replace
- ;; `disable` by `enable` in #:configure-flags when this is fixed.
- #:configure-flags '("--disable-python-bindings")
+ `(#:configure-flags '("--enable-python-bindings")
;; FIXME - Tests are disabled for now because one test hangs
;; indefinetely. Also, parallel testing is not possible because of how
;; the lttng-daemon handles sessions. Thus, keep parallel testing