summaryrefslogtreecommitdiff
path: root/gnu/packages/ipfs.scm
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2023-10-08 09:21:00 +0300
committerLudovic Courtès <ludo@gnu.org>2023-10-24 18:06:21 +0200
commit2919b5ae315976032473a2e6ee9d49d57ab9f618 (patch)
tree6b62dc39adec29108887819218963b753e0d765b /gnu/packages/ipfs.scm
parent1f6babf0c4932b6978249e618bf6d9ec3566b8be (diff)
gnu: Deprecate the "go-ipfs" variable.
* gnu/packages/ipfs.scm (go-ipfs): Rename to "kubo". (go-ipfs): Define as deprecated by "kubo". Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/ipfs.scm')
-rw-r--r--gnu/packages/ipfs.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index ac12aea002..a1a77c55a9 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -219,9 +219,9 @@ powerful and simple.")
written in Go.")
(license license:expat)))
-(define-public go-ipfs
+(define-public kubo
(package
- (name "go-ipfs")
+ (name "kubo")
(version "0.14.0")
(source
(origin
@@ -368,3 +368,6 @@ like a single bittorrent swarm, exchanging git objects. IPFS provides an
interface as simple as the HTTP web, but with permanence built in. You can
also mount the world at @code{/ipfs}.")
(license license:expat)))
+
+(define-public go-ipfs
+ (deprecated-package "go-ipfs" kubo))