summaryrefslogtreecommitdiff
path: root/gnu/packages/irc.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-06-26 13:51:26 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-06-26 13:51:26 +0200
commita167873c67a17df8175f896750de2d905d0fae04 (patch)
treee84bd2845b5456ef67e7337f54bdb3cc2e5b7512 /gnu/packages/irc.scm
parent7c3bea7e6299e1026c7964c83986a6b6c220879a (diff)
parent7c7323e432620a42f896056f076020a748c1fd6d (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/irc.scm')
-rw-r--r--gnu/packages/irc.scm40
1 files changed, 19 insertions, 21 deletions
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index 993102f272..5a1df6d600 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -133,12 +133,11 @@ irssi, but graphical.")
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
(setenv "CONFIG_SHELL" (which "bash"))
- (zero?
- (system* "./configure"
- (string-append "--prefix=" out)
- (string-append "--with-proxy")
- (string-append "--with-socks")
- (string-append "--with-bot")))))))))
+ (invoke "./configure"
+ (string-append "--prefix=" out)
+ (string-append "--with-proxy")
+ (string-append "--with-socks")
+ (string-append "--with-bot"))))))))
(inputs
`(("glib" ,glib)
("ncurses" ,ncurses)
@@ -405,21 +404,20 @@ other enhancements and bug fixes.")
'())
(setenv "CONFIG_SHELL" (which "bash"))
(setenv "SHELL" (which "bash"))
- (zero?
- (system* "./configure"
- (string-append "--prefix=" out)
- "--with-ipv6" "--with-libarchive"
- ;; We use libressl because openssl does not come
- ;; with the lib/libssl.a which is needed for epic5.
- ;; XXX: No matter which implementation is chosen,
- ;; epic5 fails to connect to tls ports of roundrobin
- ;; irc networks. This however is believed to be an
- ;; protocol issue at epic5 related to ircd.
- (string-append "--with-ssl="
- (assoc-ref %build-inputs "libressl"))
- (string-append "--with-tcl="
- (assoc-ref %build-inputs "tcl")
- "/lib/tclConfig.sh")))))))))
+ (invoke "./configure"
+ (string-append "--prefix=" out)
+ "--with-ipv6" "--with-libarchive"
+ ;; We use libressl because openssl does not come
+ ;; with the lib/libssl.a which is needed for epic5.
+ ;; XXX: No matter which implementation is chosen,
+ ;; epic5 fails to connect to tls ports of roundrobin
+ ;; irc networks. This however is believed to be an
+ ;; protocol issue at epic5 related to ircd.
+ (string-append "--with-ssl="
+ (assoc-ref %build-inputs "libressl"))
+ (string-append "--with-tcl="
+ (assoc-ref %build-inputs "tcl")
+ "/lib/tclConfig.sh"))))))))
(inputs
`(("libressl" ,libressl)
("ncurses" ,ncurses)