summaryrefslogtreecommitdiff
path: root/gnu/packages/irc.scm
diff options
context:
space:
mode:
authorSébastien Helleu <flashcode@flashtux.org>2023-01-09 22:18:58 +0100
committer宋文武 <iyzsong@member.fsf.org>2023-01-12 11:00:53 +0800
commit501b80afadc4f6d599465523cad6aa2486312e48 (patch)
tree254cfdcc7992a50c981d0c8bb958508d4f612fe6 /gnu/packages/irc.scm
parent9aa3b6eb6d778f90b078ba758ea96ef9ee364ffe (diff)
gnu: weechat: Update to 3.8.
* gnu/packages/irc.scm (weechat): Update to 3.8. [arguments]: Do not build tests any more: since version 3.8, ‘make test’ is successful when tests are not built. [native-inputs]: Remove dependency on cpputest as tests are not built any more. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/irc.scm')
-rw-r--r--gnu/packages/irc.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index 0a6c28980d..d850e9c916 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -195,14 +195,14 @@ Conferencing} and @acronym{ICB, Internet Citizen's Band}.")
(define-public weechat
(package
(name "weechat")
- (version "3.6")
+ (version "3.8")
(source (origin
(method url-fetch)
(uri (string-append "https://weechat.org/files/src/weechat-"
version ".tar.xz"))
(sha256
(base32
- "1ppj676gwh67krq92xnfkmh3qnwbz8d51djsscxw013x7cdxg1cx"))))
+ "0a5zfkqqdkya111rl2gpwlbfala0305qry9cdz2r1h7q0316bjzp"))))
(build-system cmake-build-system)
(outputs '("out" "doc"))
(native-inputs
@@ -210,9 +210,7 @@ Conferencing} and @acronym{ICB, Internet Citizen's Band}.")
("pkg-config" ,pkg-config)
,@(if (target-x86?)
`(("ruby-asciidoctor" ,ruby-asciidoctor))
- '())
- ;; For tests.
- ("cpputest" ,cpputest)))
+ '())))
(inputs
(list aspell
curl
@@ -234,8 +232,7 @@ Conferencing} and @acronym{ICB, Internet Citizen's Band}.")
,@(if (target-x86?)
'("-DENABLE_MAN=ON"
"-DENABLE_DOC=ON")
- '())
- "-DENABLE_TESTS=ON") ; ‘make test’ fails otherwise
+ '()))
#:phases
(modify-phases %standard-phases
,@(if (target-x86?)