summaryrefslogtreecommitdiff
path: root/gnu/packages/irc.scm
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2023-01-08 19:11:08 -0600
committerChristopher Baines <mail@cbaines.net>2023-02-17 15:44:59 +0000
commita558998f7dabb2c0672abe3aaac89fb9b652cbb1 (patch)
tree9947bdf19b26bbc995fd2c6db463ba9c00bbde43 /gnu/packages/irc.scm
parent395c4aa880c2b666d10abe2ceeda6abf3fe15390 (diff)
gnu: Add chathistorysync.
* gnu/packages/irc.scm (chathistorysync): New variable. Co-authored-by: ( <paren@disroot.org> Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/irc.scm')
-rw-r--r--gnu/packages/irc.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index 1b2af63383..4bce2d2d47 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -615,6 +615,51 @@ interface for those who are accustomed to the ircII way of doing things.")
building block for other projects.")
(license license:expat)))
+(define-public chathistorysync
+ (package
+ (name "chathistorysync")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~emersion/chathistorysync")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "03dxr178wnicggx0k95wvyzgyk4s4g0adbi2z0md517a5qd1lh23"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "git.sr.ht/~emersion/chathistorysync"
+ #:install-source? #f ; chathistorysync is an end-user application.
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'build 'doc
+ (lambda _
+ (with-directory-excursion
+ "src/git.sr.ht/~emersion/chathistorysync"
+ (invoke "sh" "-c"
+ "scdoc <chathistorysync.1.scd >chathistorysync.1"))))
+ (add-after 'install 'install-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out")))
+ (with-directory-excursion
+ "src/git.sr.ht/~emersion/chathistorysync"
+ (install-file
+ "chathistorysync.1"
+ (string-append out "/share/man/man1")))))))))
+ (inputs
+ (list go-golang-org-x-sys
+ go-golang-org-x-term
+ go-golang-org-x-crypto
+ go-gopkg-in-irc-v3))
+ (native-inputs (list scdoc))
+ (home-page "https://git.sr.ht/~emersion/chathistorysync")
+ (synopsis "Synchronization tool for IRC chat history")
+ (description
+ "This package provides a synchronization tool for IRC chat history.")
+ (license license:agpl3)))
+
(define-public litterbox
(package
(name "litterbox")