summaryrefslogtreecommitdiff
path: root/gnu/packages/jami.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-25 16:42:49 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-31 21:55:50 -0400
commitf80f1667f1fe199fe89202da29da056195ca301b (patch)
tree0f982ff08878581737fdb8e4f282971e4b1169fc /gnu/packages/jami.scm
parent46f5623cc19805c8d65011b2650be85156769c86 (diff)
gnu: Deprecate jami-gnome for jami.
* gnu/packages/jami.scm (jami-gnome): Delete package, deprecating it for jami.
Diffstat (limited to 'gnu/packages/jami.scm')
-rw-r--r--gnu/packages/jami.scm63
1 files changed, 4 insertions, 59 deletions
diff --git a/gnu/packages/jami.scm b/gnu/packages/jami.scm
index de80c8a64f..f99cd2f14c 100644
--- a/gnu/packages/jami.scm
+++ b/gnu/packages/jami.scm
@@ -474,65 +474,6 @@ protocols, as well as decentralized calling using P2P-DHT.")
(define-public libring
(deprecated-package "libring" libjami))
-(define-public jami-gnome
- (package
- (name "jami-gnome")
- (version %jami-version)
- (source %jami-sources)
- (outputs '("out" "debug"))
- (build-system cmake-build-system)
- (arguments
- `(#:tests? #f ;no test suite
- #:imported-modules (,@%cmake-build-system-modules
- (guix build glib-or-gtk-build-system))
- #:modules ((guix build cmake-build-system)
- ((guix build glib-or-gtk-build-system) #:prefix gtk:)
- (guix build utils))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'change-directory/maybe
- (lambda _
- ;; Allow building from the tarball or a git checkout.
- (false-if-exception (chdir "client-gnome"))))
- (add-after 'change-directory/maybe 'fix-webkit-detection
- (lambda _
- (substitute* "CMakeLists.txt"
- (("WEBKIT webkit2gtk-4.0")
- "WEBKIT webkit2gtk-4.1"))))
- (add-after 'change-directory/maybe 'fix-version-string
- (lambda _
- (substitute* "CMakeLists.txt"
- (("^# Set VERSION.*" anchor)
- (string-append anchor
- "set(PROJECT_VERSION \"" ,version "\")\n")))))
- (add-after 'install 'glib-or-gtk-compile-schemas
- (assoc-ref gtk:%standard-phases 'glib-or-gtk-compile-schemas))
- (add-after 'glib-or-gtk-compile-schemas 'glib-or-gtk-wrap
- (assoc-ref gtk:%standard-phases 'glib-or-gtk-wrap)))))
- (inputs
- (list clutter
- clutter-gtk
- gtk+
- libcanberra
- libappindicator
- libnotify
- network-manager
- qrencode
- sqlite
- webkitgtk))
- (native-inputs
- (list pkg-config
- gettext-minimal
- `(,glib "bin"))) ;for glib-compile-resources
- (synopsis "Jami client for GNOME")
- (description "This package provides a Jami client for the GNOME desktop.
-Jami is a secure and distributed voice, video and chat communication platform
-that requires no centralized server and leaves the power of privacy in the
-hands of the user. It supports the SIP and IAX protocols, as well as
-decentralized calling using P2P-DHT.")
- (home-page "https://jami.net")
- (license license:gpl3+)))
-
(define-public jami
(package
(name "jami")
@@ -588,5 +529,9 @@ P2P-DHT.")
(license license:gpl3+)))
;;; Remove when 2023 comes.
+(define-public jami-gnome
+ (deprecated-package "jami-gnome" jami))
+
+;;; Remove when 2023 comes.
(define-public jami-qt
(deprecated-package "jami-qt" jami))