summaryrefslogtreecommitdiff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-10-24 22:05:04 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-11-02 13:06:38 +0100
commit11bc385b7b3a1e2a06ca93f39dc211572c4e5d89 (patch)
tree6f83cbf92d1a710bbe131ce4fb500f9cb062bdce /gnu/packages/java.scm
parenta6dd06d0e2297c4eabbfcb5461ee6560cd0b2f95 (diff)
gnu: Add java-bsh.
* gnu/packages/java.scm (java-bsh): New variable.
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 5263dcc430..a9df37ee4e 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -6273,3 +6273,36 @@ file when the JVM loads it.")
trivial to parse command line parameters. Parameters are declared with
annotations.")
(license license:asl2.0)))
+
+(define-public java-bsh
+ (package
+ (name "java-bsh")
+ (version "2.0b6")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/beanshell/beanshell/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1bawkxk6jyc75hxvzkpz689h73cn3f222m0ar3nvb0dal2b85kfv"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:build-target "jarall"
+ #:test-target "junit-tests-all"
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((share (string-append (assoc-ref outputs "out") "/share/java")))
+ (mkdir-p share)
+ (copy-file "dist/bsh-2.0b6.jar" (string-append share "/bsh-2.0b6.jar"))
+ #t))))))
+ (home-page "http://beanshell.org/")
+ (synopsis "Lightweight Scripting for Java")
+ (description "BeanShell is a small, free, embeddable Java source
+interpreter with object scripting language features, written in Java.
+BeanShell dynamically executes standard Java syntax and extends it with common
+scripting conveniences such as loose types, commands, and method closures like
+those in Perl and JavaScript.")
+ (license license:asl2.0)))