summaryrefslogtreecommitdiff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-10-14 23:06:11 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-10-23 22:55:12 +0200
commit5d104a27565eea05302c2e3cd8ee2f4f5a8e1260 (patch)
tree28bdfe2178d39f17270c4ba4f3c194d247f89b19 /gnu/packages/java.scm
parent213bb981801f5c001d1066852e855dff253ab008 (diff)
gnu: Add java-aopalliance.
* gnu/packages/java.scm (java-aopalliance): New variable.
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 901d16eabb..07a50c4674 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -6059,3 +6059,33 @@ is expressed as the number of significant digits in the value recording, and
provides control over value quantization behavior across the value range and
the subsequent value resolution at any given level.")
(license license:public-domain)))
+
+(define-public java-aopalliance
+ (package
+ (name "java-aopalliance")
+ (version "1.0")
+ (source (origin
+ (method git-fetch)
+ ;; Note: this git repository is not official, but contains the
+ ;; source code that is in the CVS repository. Downloading the
+ ;; tarball from sourceforge is undeterministic, and the cvs download
+ ;; fails.
+ (uri (git-reference
+ (url "https://github.com/hoverruan/aopalliance")
+ (commit "0d7757ae204e5876f69431421fe9bc2a4f01e8a0")))
+ (file-name (string-append name "-" version))
+ (sha256
+ (base32
+ "0rsg2b0v3hxlq2yk1i3m2gw3xwq689j3cwx9wbxvqfpdcjbca0qr"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:jar-name "java-aopalliance.jar"
+ #:jdk ,icedtea-8
+ #:tests? #f; no tests
+ #:source-dir "aopalliance/src/main"))
+ (home-page "http://aopalliance.sourceforge.net")
+ (synopsis "Aspect-Oriented Programming")
+ (description "The AOP Alliance project is a joint project between several
+software engineering people who are interested in Aspect-Oriented Programming
+(AOP) and Java.")
+ (license license:public-domain)))