summaryrefslogtreecommitdiff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-06 11:49:12 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-06 11:49:12 +0100
commitfab959d30811b0c6cf0a47d2ab514a8883a8f115 (patch)
tree89cd10a27cd1cc6030a04364b1201691492946e8 /gnu/packages/java.scm
parente5213cd63b1cdda7fa900c7f44eaf990330c6d55 (diff)
gnu: java-hamcrest-core: Fix build.
Since we now remove the directory "lib" from the source, we need to create a directory where build.xml searches for .jar-files. * gnu/packages/java.scm (java-hamcrest-core)[pahases]: New phase create-dummy-directories.
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 612a2c2d8a..df8a970e0c 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -1237,6 +1237,12 @@ private Method[] allMethods = getSortedMethods();")))))
(string-append (assoc-ref inputs "java-qdox-1.12")
"/share/java/qdox.jar")))
#t))
+ ;; build.xml searches for .jar files in this directoy, which
+ ;; we remove from the source archive.
+ (add-before 'build 'create-dummy-directories
+ (lambda _
+ (mkdir-p "lib/integration")
+ #t))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(install-file (string-append "build/hamcrest-core-"