summaryrefslogtreecommitdiff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2016-04-27 00:00:44 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-04-27 10:52:34 +0200
commit068e476f68dd6eea9cb90269997d862025fbd696 (patch)
tree809eb94cdc03a1015896a72e20eef6b1d65424d5 /gnu/packages/java.scm
parent5135354f62765ec41edaab541f519888b8e197f8 (diff)
gnu: Add java-xz.
* gnu/packages/java.scm (java-xz): New variable.
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index d6ad28fd1b..c94f2e4b28 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -22,6 +23,7 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix utils)
+ #:use-module (guix build-system ant)
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
#:use-module (gnu packages attr)
@@ -829,3 +831,31 @@ build process and its dependencies, whereas Make uses Makefile format.")
"jdk-drop" "langtools-drop" "hotspot-drop")))))))
(define-public icedtea icedtea-7)
+
+(define-public java-xz
+ (package
+ (name "java-xz")
+ (version "1.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://tukaani.org/xz/xz-java-" version ".zip"))
+ (sha256
+ (base32
+ "0x6vn9dp9kxk83x2fp3394n95dk8fx9yg8jns9371iqsn0vy8ih1"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:tests? #f ; There are no tests to run.
+ #:jar-name ,(string-append "xz-" version ".jar")
+ #:phases
+ (modify-phases %standard-phases
+ ;; The unpack phase enters the "maven" directory by accident.
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "..") #t)))))
+ (native-inputs
+ `(("unzip" ,unzip)))
+ (home-page "http://tukaani.org/xz/java.html")
+ (synopsis "Implementation of XZ data compression in pure Java")
+ (description "This library aims to be a complete implementation of XZ data
+compression in pure Java. Single-threaded streamed compression and
+decompression and random access decompression have been fully implemented.")
+ (license license:public-domain)))