summaryrefslogtreecommitdiff
path: root/gnu/packages/javascript.scm
diff options
context:
space:
mode:
authorZheng Junjie <873216071@qq.com>2023-07-17 12:10:57 +0800
committer宋文武 <iyzsong@member.fsf.org>2024-03-19 18:35:57 +0800
commit8a4ed004d6b0720f47fc6ef5f0247a66a42a2f7c (patch)
treece0a98920cf6ce4054c70383d10447ed5ba108d3 /gnu/packages/javascript.scm
parentefad468f6d51133c967205c8b9fb8e52a8bfd05e (diff)
gnu: quickjs: Honor the #:tests? flag.
* gnu/packages/javascript.scm (quickjs)[arguments]: Adjust custom 'check phase to honor the #:tests? flag. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Change-Id: I686b3b9a615cbdaefaf59d9c1c0ba7628d7d92f2
Diffstat (limited to 'gnu/packages/javascript.scm')
-rw-r--r--gnu/packages/javascript.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/javascript.scm b/gnu/packages/javascript.scm
index a1c0d9ad01..c6e7443f85 100644
--- a/gnu/packages/javascript.scm
+++ b/gnu/packages/javascript.scm
@@ -843,8 +843,9 @@ roots, or wrestle with obscure build systems.")
#:phases #~(modify-phases %standard-phases
(delete 'configure)
(replace 'check
- (lambda _
- (invoke "make" "microbench"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "make" "microbench")))))))
(home-page "https://bellard.org/quickjs/")
(synopsis "Small embeddable Javascript engine")
(description "QuickJS supports the ES2020 specification including modules,