summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-jll.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 11:00:20 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:50 +0300
commit75ea06d8db27fb58fcf7a673af367b8805598d52 (patch)
tree3284ab17864aedede2dad3bdc383e152f7924de7 /gnu/packages/julia-jll.scm
parentd3f8731b63bca5fc39ef9973d7b928fae1977e9b (diff)
gnu: Add julia-ogg-jll.
* gnu/packages/julia-jll.scm (julia-ogg-jll): New variable.
Diffstat (limited to 'gnu/packages/julia-jll.scm')
-rw-r--r--gnu/packages/julia-jll.scm39
1 files changed, 38 insertions, 1 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index ec3253cb14..1cf9b7deff 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -37,7 +37,8 @@
#:use-module (gnu packages mp3)
#:use-module (gnu packages tls)
#:use-module (gnu packages video)
- #:use-module (gnu packages web))
+ #:use-module (gnu packages web)
+ #:use-module (gnu packages xiph))
;;; TODO: Remove this autogenerated source package
;;; and build it from realse source using <https://github.com/JuliaPackaging/Yggdrasil/>
@@ -552,6 +553,42 @@ used in autogenerated packages via @code{BinaryBuilder.jl}.")
wrappers.")
(license license:expat)))
+(define-public julia-ogg-jll
+ (package
+ (name "julia-ogg-jll")
+ (version "1.3.4+0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaBinaryWrappers/Ogg_jll.jl")
+ (commit (string-append "Ogg-v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0p27wgy48gfw8g0hzlvcxrp0346nqnyxa88pydm87ll3sfx9b4ww"))))
+ (build-system julia-build-system)
+ (arguments
+ '(#:tests? #f ; no runtests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'override-binary-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (map
+ (lambda (wrapper)
+ (substitute* wrapper
+ (("artifact\"Ogg\"")
+ (string-append "\"" (assoc-ref inputs "libogg") "\""))))
+ ;; There's a Julia file for each platform, override them all
+ (find-files "src/wrappers/" "\\.jl$")))))))
+ (inputs
+ `(("libogg" ,libogg)))
+ (propagated-inputs
+ `(("julia-jllwrappers" ,julia-jllwrappers)))
+ (home-page "https://github.com/JuliaBinaryWrappers/Ogg_jll.jl")
+ (synopsis "Libogg library wrappers")
+ (description "This package provides a wrapper for the libogg library.")
+ (license license:expat)))
+
(define-public julia-openspecfun-jll
(let ((commit "6c505cce3bdcd9cd2b15b4f9362ec3a42c4da71c"))
(package