summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-12-12 12:50:42 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-12-21 17:59:34 +0200
commit2bd22272daeabd37b00c7fcfd63c2d50c97e2747 (patch)
tree35285f74e5b5c0d5114c4388df66379743f26187 /gnu/packages/julia-xyz.scm
parentc8fed74a3a87eccd59a11f1154e65b7dcd94e1fe (diff)
gnu: julia-mappedarrays: Update to 0.4.1.
* gnu/packages/julia-xyz.scm (julia-mappedarrays): Update to 0.4.1. [source]: Add snippet to fix deprecation warning and to fix the testsuite. [arguments]: Add 'adjust-tests phase to skip a test and absorb the i686-linux specific phase 'fix-tests-int32-i686. [native-inputs]: Remove julia-colortypes. Add julia-colors.
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm34
1 files changed, 24 insertions, 10 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index b31ef2faac..01a3569e8d 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -3438,7 +3438,7 @@ that let you do deep transformations of code.")
(define-public julia-mappedarrays
(package
(name "julia-mappedarrays")
- (version "0.4.0")
+ (version "0.4.1")
(source
(origin
(method git-fetch)
@@ -3447,22 +3447,36 @@ that let you do deep transformations of code.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0l5adird8m1cmnsxwhzi5hcr7q9bm1rf7a6018zc7kcn2yxdshy3"))))
+ (base32 "08kb28dv1zzqbbxblhyllgs4sjxyp76dgjqhdizcq4zg4i1kls6p"))
+ (snippet
+ #~(begin
+ (use-modules (guix build utils))
+ ;; Fix deprecation warning
+ ;; https://github.com/JuliaArrays/MappedArrays.jl/pull/51
+ (substitute* "src/MappedArrays.jl"
+ (("Vararg\\{<:AbstractArray") "Vararg{AbstractArray"))
+ ;; Fix test failures
+ ;; https://github.com/JuliaArrays/MappedArrays.jl/pull/50
+ (substitute* "test/runtests.jl"
+ (("_zero\\(x\\) = x > 0 \\? x : 0")
+ "_zero(x) = ismissing(x) ? x : (x > 0 ? x : 0)"))))))
(build-system julia-build-system)
(arguments
(list
#:phases
- (if (target-64bit?)
- #~%standard-phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'fix-tests-int32-i686
- (lambda _
- (substitute* "test/runtests.jl"
- (("Int64") "Int32"))))))))
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'adjust-tests
+ (lambda _
+ (substitute* "test/runtests.jl"
+ ((".*@test_throws ErrorException b.*") ""))
+
+ (when #$(not (target-64bit?))
+ (substitute* "test/runtests.jl"
+ (("Int64") "Int32"))))))))
(propagated-inputs
(list julia-fixedpointnumbers))
(native-inputs
- (list julia-colortypes
+ (list julia-colors
julia-fixedpointnumbers
julia-offsetarrays))
(home-page "https://github.com/JuliaArrays/MappedArrays.jl")