summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-12-14 14:55:55 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-12-21 19:22:54 +0200
commit2c838a6fc75b0289714694ce0435b5811fb9e9ce (patch)
tree8b31fd045b34c55fb7931844add94621a2c295c0 /gnu/packages/julia-xyz.scm
parentd0d99aa75cd7e2959b38d2c5220c672eee8f8f09 (diff)
gnu: julia-indexablebitvectors: Limit to 64-bit systems.
* gnu/packages/julia-xyz.scm (julia-indexablebitvectors) [supported-systems]: New field.
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index d838c4677d..cae6b9237c 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -2903,6 +2903,9 @@ number of occurrences of bit @code{b} in @code{bv[1:i]}
index of i-th occurrence of @code{b} in @code{bv}.
@end itemize
and other shortcuts or types.")
+ ;; There are plenty of places in the code which rely on the
+ ;; length of an Integer in a 64-bit system.
+ (supported-systems %64bit-supported-systems)
(license license:expat)))
(define-public julia-indexing