summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-12-14 12:50:35 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-12-21 19:22:45 +0200
commita1cfa757d75cf2b87a5298ce1ced9adf0c9e39b4 (patch)
tree4716f9126cf215f9cf7fb92ee69eb2bac83ba8a0 /gnu/packages/julia-xyz.scm
parent4ec253bdf4dab1d079fb364fc85430f8734bc463 (diff)
gnu: Add julia-inversefunctions.
* gnu/packages/julia-xyz.scm (julia-inversefunctions): New variable.
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 3c854c729a..068b4742cd 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -3060,6 +3060,27 @@ container mapping @code{(K,V)} pairs via the type @code{IntervalTree{K, V}}.
The type @code{K} may be any ordered type.")
(license license:expat))))
+(define-public julia-inversefunctions
+ (package
+ (name "julia-inversefunctions")
+ (version "0.1.8")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaMath/InverseFunctions.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "05g9f6i735x7syfr56l4yf4fy71kgdisjc6cfxi4jkf46iq86a69"))))
+ (build-system julia-build-system)
+ (native-inputs
+ (list julia-documenter))
+ (home-page "https://github.com/JuliaMath/InverseFunctions.jl")
+ (synopsis "Interface for function inversion")
+ (description "This package provides an interface to invert functions.")
+ (license license:expat)))
+
(define-public julia-invertedindices
(package
(name "julia-invertedindices")