summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-12-14 12:51:45 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-12-21 19:22:44 +0200
commitc822cb7cb501da46afb478fd5a59cf68f4a8fbf5 (patch)
tree477f5b83856bc4752aa40deec09380372aefc1cd /gnu/packages/julia-xyz.scm
parenta7762f14b74abedabd1c8b58dd096d9de8c98f10 (diff)
gnu: Remove julia-identityranges.
* gnu/packages/julia-xyz.scm (julia-identityranges): Delete variable.
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm26
1 files changed, 0 insertions, 26 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 81722de859..e072a76e18 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -2475,32 +2475,6 @@ library for parsing HTML.")
implementing both a client and a server.")
(license license:expat)))
-(define-public julia-identityranges
- (package
- (name "julia-identityranges")
- (version "0.3.1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/JuliaArrays/IdentityRanges.jl")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0jvl4xn8f8k70sn473li5q62wbiycl5qi25b5k456h3a0j1lbiml"))))
- (build-system julia-build-system)
- (propagated-inputs
- (list julia-offsetarrays))
- (home-page "https://github.com/JuliaArrays/IdentityRanges.jl")
- (synopsis "Ranges that preserve indices of views")
- (description "@code{IdentityRanges} are Julia-language a helper type for
-creating \"views\" of arrays. They are a custom type of AbstractUnitRange that
-makes it easy to preserve the indices of array views. The key property of an
-@code{IdentityRange r} is that @code{r[i] == i} (hence the name of the
-type/package), and that they support arbitrary start/stop indices (i.e., not
-just starting at 1).")
- (license license:expat)))
-
(define-public julia-ifelse
(package
(name "julia-ifelse")