summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-12-14 19:39:16 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-12-21 19:22:56 +0200
commit204ad23d796aa004461044f3504f825309a13ac6 (patch)
tree2b39763b21dbd79f136359efa7e71f0273460584 /gnu/packages/julia-xyz.scm
parent611d7427ebb471d636748026cd35bcfb5238881b (diff)
gnu: julia-ellipsisnotation: Update to 1.6.0.
* gnu/packages/julia-xyz.scm (julia-ellipsisnotation): Update to 1.6.0. [arguments]: Remove phase adjusting the test suite.
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm13
1 files changed, 2 insertions, 11 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index cdd29504cf..81d59ff620 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1801,7 +1801,7 @@ combinations of dual numbers with predefined Julia numeric types.")
(define-public julia-ellipsisnotation
(package
(name "julia-ellipsisnotation")
- (version "1.1.0")
+ (version "1.6.0")
(source
(origin
(method git-fetch)
@@ -1810,17 +1810,8 @@ combinations of dual numbers with predefined Julia numeric types.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0py46kxl702r8pw3v7x4cqllf7yc91b0dr7vb60xh2qi7d6y3jc7"))))
+ (base32 "0l4fc180chhxlq9d67122c0lgq2hfsxsmcgml2bfl2rnh13gya2b"))))
(build-system julia-build-system)
- (arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'link-depot 'adjust-test-suite
- (lambda _
- (substitute* "test/runtests.jl"
- ;; Seems to not play nicely with Julia-1.6.
- ((".*basic.jl.*") "")))))))
(propagated-inputs
(list julia-arrayinterface))
(home-page "https://github.com/ChrisRackauckas/EllipsisNotation.jl")