summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-12-03 00:26:35 +0000
committerEfraim Flashner <efraim@flashner.co.il>2023-12-04 11:52:26 +0200
commita2f7a37a982a04f4a49eb549050da8df08ce6c63 (patch)
tree0b211009c742c611ec0ce2ccd3fbc6e0b687e1c3 /gnu/packages/julia-xyz.scm
parent0a4b6fd51a2a4f87cbd85019db07984fd37096d7 (diff)
gnu: Add julia-astrolib.
* gnu/packages/julia-xyz.scm (julia-astrolib): New variable. Change-Id: I41fc21728b3bc2d20c2e6c83a6ea1185086a015e Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 82df28d9b5..3974bbdd2a 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -265,6 +265,28 @@ appropriate BLAS or optimised Julia linear algebra routines. This supports a
much wider class of matrix types than Julia's in-built @code{StridedArray}.")
(license license:expat)))
+(define-public julia-astrolib
+ (package
+ (name "julia-astrolib")
+ (version "0.4.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaAstro/AstroLib.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1zbivs79cw7qazrl9c8rz2n2kifxw3adwjf22nn24dp5i34fkw5d"))))
+ (build-system julia-build-system)
+ (native-inputs (list julia-staticarrays))
+ (home-page "https://github.com/JuliaAstro/AstroLib.jl")
+ (synopsis "Bundle of small astronomical and astrophysical routines")
+ (description "The aim of this package is to provide users with a set of small
+generic routines useful above all in astronomical and astrophysical context,
+written in Julia.")
+ (license license:expat)))
+
(define-public julia-astrotime
(package
(name "julia-astrotime")