summaryrefslogtreecommitdiff
path: root/gnu/packages/julia.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-08-12 00:30:27 +0200
committerMarius Bakke <marius@gnu.org>2021-08-12 00:30:27 +0200
commitc4133c43c7cfe2476ebfae87f9e4d10d96de9bc7 (patch)
tree47bd773d2f434384b54e56916c1a287dd8e51511 /gnu/packages/julia.scm
parentffa01e68859bb7a6daa9fcffdc8d77ca35db4bc0 (diff)
parent4eb0a5146ae5a195a29c79f586fcc1e58f7fa69b (diff)
Merge branch 'master' into core-updates-frozen
Conflicts: gnu/packages/algebra.scm gnu/packages/games.scm gnu/packages/golang.scm gnu/packages/kerberos.scm gnu/packages/mail.scm gnu/packages/python.scm gnu/packages/ruby.scm gnu/packages/scheme.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/version-control.scm
Diffstat (limited to 'gnu/packages/julia.scm')
-rw-r--r--gnu/packages/julia.scm31
1 files changed, 23 insertions, 8 deletions
diff --git a/gnu/packages/julia.scm b/gnu/packages/julia.scm
index df8a74fea5..f5bbb5d267 100644
--- a/gnu/packages/julia.scm
+++ b/gnu/packages/julia.scm
@@ -32,7 +32,6 @@
#:use-module (gnu packages)
#:use-module (gnu packages algebra)
#:use-module (gnu packages base)
- #:use-module (gnu packages certs)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
#:use-module (gnu packages elf)
@@ -273,7 +272,7 @@ libraries. It is also a bit like @code{ldd} and @code{otool -L}.")
(define-public julia
(package
(name "julia")
- (version "1.6.1")
+ (version "1.6.2")
(source (origin
(method url-fetch)
(uri (string-append
@@ -281,7 +280,7 @@ libraries. It is also a bit like @code{ldd} and @code{otool -L}.")
version "/julia-" version ".tar.gz"))
(sha256
(base32
- "1mfzbjyqcmx7wb1sa7qab5fl78yzd7ap088krqbphbwvpn880srn"))
+ "0plbj4laifzz8ppk889iv3gaxj1mdddzv7yad6ghml6bfnn24r6m"))
(patches
(search-patches "julia-SOURCE_DATE_EPOCH-mtime.patch"))))
(build-system gnu-build-system)
@@ -341,6 +340,26 @@ libraries. It is also a bit like @code{ldd} and @code{otool -L}.")
(("\\$\\$\\(build_depsbindir\\)/libwhich")
(search-input-file inputs "/bin/libwhich")))
#t))
+ (add-after 'unpack 'change-number-of-precompile-statements
+ (lambda _
+ ;; Remove nss-certs drops the number of statements below 1200,
+ ;; causing the build to fail prematurely.
+ (substitute* "contrib/generate_precompile.jl"
+ (("1200") "1100"))
+ #t))
+ ;; For some reason libquadmath is unavailable on this architecture.
+ ;; https://github.com/JuliaLang/julia/issues/41613
+ ,@(if (target-aarch64?)
+ '((add-after 'unpack 'drop-libquadmath-on-aarch64
+ (lambda _
+ (substitute* '("contrib/fixup-libgfortran.sh"
+ "deps/csl.mk"
+ "base/Makefile")
+ ((".*libquadmath.*") ""))
+ (substitute* "Makefile"
+ (("libquadmath ") ""))
+ #t)))
+ '())
(add-before 'check 'set-home
;; Some tests require a home directory to be set.
(lambda _ (setenv "HOME" "/tmp") #t))
@@ -484,9 +503,6 @@ libraries. It is also a bit like @code{ldd} and @code{otool -L}.")
"@test_broken ispath(ca_roots_path())")
(("@test ca_roots_path\\(\\) \\!= bundled_ca_roots\\(\\)")
"@test_broken ca_roots_path() != bundled_ca_roots()"))
- ;; Some digraphs are too wide for some terminals during testing.
- (substitute* "stdlib/Unicode/test/runtests.jl"
- (("test collect\\(graphemes") "test_broken collect(grapemes"))
;; WARNING: failed to select UTF-8 encoding, using ASCII
;; Using 'setlocale' doesn't affect the test failures.
;(setlocale LC_ALL "en_US.utf8")
@@ -644,8 +660,7 @@ libraries. It is also a bit like @code{ldd} and @code{otool -L}.")
("dsfmt" ,dsfmt)
("libwhich" ,libwhich)))
(native-inputs
- `(("nss-certs" ,nss-certs)
- ("openssl" ,openssl)
+ `(("openssl" ,openssl)
("perl" ,perl)
("patchelf" ,patchelf)
("pkg-config" ,pkg-config)