summaryrefslogtreecommitdiff
path: root/gnu/packages/julia.scm
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-05-27 19:27:33 +0800
committerHilton Chain <hako@ultrarare.space>2024-02-05 13:56:31 +0800
commit2b296427d7bd7b6b155e0e94403c1227ce014008 (patch)
tree794cff1bf5b76cfa279b857af03fd0d5abd4f35a /gnu/packages/julia.scm
parent0f86c1c6f887513692b4e908e21884c2705b5e82 (diff)
gnu: mbedtls-apache: Rename to mbedtls-lts.
* gnu/packages/tls.scm (mbedtls-apache): Rename package to "mbedtls". Rename variable to… (mbedtls-lts): …this. (mbedtls-apache): Define as deprecated by mbedtls-lts. (mbedtls-for-hiawatha): Adjust accordingly. * doc/guix.texi: Likewise. * gnu/packages/emulators.scm (dolphin-emu,retroarch)[inputs]: Likewise. * gnu/packages/game-development.scm (godot-lts,godot)[inputs]: Likewise. * gnu/packages/hardware.scm (hueplusplus,openrgb)[inputs]: Likewise. * gnu/packages/haxe.scm (neko,haxe,hashlink)[inputs]: Likewise. * gnu/packages/irc.scm (inspircd)[inputs]: Likewise. * gnu/packages/julia-jll.scm (julia-mbedtls-jll)[arguments]<#:phases>,[inputs]: Likewise. * gnu/packages/julia.scm (julia)[arguments]<#:phases>,[inputs]: Likewise. * gnu/packages/linphone.scm (bctoolbox)[inputs]: Likewise. * gnu/packages/linux.scm (dislocker)[inputs]: Likewise. * gnu/packages/networking.scm (nng)[inputs]: Likewise. * gnu/packages/search.scm (dataparksearch)[inputs]: Likewise. * gnu/packages/video.scm (obs)[inputs]: Likewise. * gnu/packages/web.scm (hiawatha)[arguments]<#:phases>: Likewise. Change-Id: I0c58b3cd0bcf6e44e7b16a69f6d2739aa3c1545b
Diffstat (limited to 'gnu/packages/julia.scm')
-rw-r--r--gnu/packages/julia.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/julia.scm b/gnu/packages/julia.scm
index 8ba2b480ce..18f0d6c7d3 100644
--- a/gnu/packages/julia.scm
+++ b/gnu/packages/julia.scm
@@ -186,7 +186,7 @@ libraries. It is also a bit like @code{ldd} and @code{otool -L}.")
"gmp" "lapack"
"libssh2" "libnghttp2" "libgit2"
"libblastrampoline"
- "mbedtls-apache" "mpfr"
+ "mbedtls" "mpfr"
"openblas" "openlibm" "pcre2"
"suitesparse" "gfortran:lib"))
":"))))
@@ -263,9 +263,9 @@ libraries. It is also a bit like @code{ldd} and @code{otool -L}.")
(substitute* (jlpath "MPFR")
(((from "libmpfr")) (to "mpfr" "libmpfr")))
(substitute* (jlpath "MbedTLS")
- (((from "libmbedcrypto")) (to "mbedtls-apache" "libmbedcrypto"))
- (((from "libmbedtls")) (to "mbedtls-apache" "libmbedtls"))
- (((from "libmbedx509")) (to "mbedtls-apache" "libmbedx509")))
+ (((from "libmbedcrypto")) (to "mbedtls" "libmbedcrypto"))
+ (((from "libmbedtls")) (to "mbedtls" "libmbedtls"))
+ (((from "libmbedx509")) (to "mbedtls" "libmbedx509")))
(substitute* (jlpath "nghttp2")
(((from "libnghttp2")) (to "libnghttp2" "libnghttp2")))
(substitute* (jlpath "OpenBLAS")
@@ -318,7 +318,7 @@ libraries. It is also a bit like @code{ldd} and @code{otool -L}.")
(substitute* "stdlib/PCRE2_jll/test/runtests.jl"
(("10.40.0") ,(package-version (this-package-input "pcre2"))))
(substitute* "stdlib/MbedTLS_jll/test/runtests.jl"
- (("2.28.0") ,(package-version (this-package-input "mbedtls-apache"))))
+ (("2.28.0") ,(package-version (this-package-input "mbedtls"))))
(substitute* "stdlib/MPFR_jll/test/runtests.jl"
(("4.1.0") ,(package-version (this-package-input "mpfr"))))
(substitute* "stdlib/GMP_jll/test/runtests.jl"
@@ -515,7 +515,7 @@ using Dates: @dateformat_str, Date, DateTime, DateFormat, Time"))
("libunwind" ,libunwind-julia)
("libuv" ,libuv-julia)
("llvm" ,llvm-julia)
- ("mbedtls-apache" ,mbedtls-apache)
+ ("mbedtls" ,mbedtls-lts)
("mpfr" ,mpfr)
,@(if (target-x86-64?)
`(("openblas" ,openblas-ilp64))