summaryrefslogtreecommitdiff
path: root/gnu/packages/julia.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-02-09 01:46:34 -0500
committerMark H Weaver <mhw@netris.org>2018-02-09 01:46:34 -0500
commitefe2a2833c6d306d0c60127fdfebaff6dc415b4c (patch)
treebf842134e1a149770907e1956d28c3a6b207b3f7 /gnu/packages/julia.scm
parent53f826cd0f429864d46fc3bf6305c14356d0b2ad (diff)
parent8d0edc8246389c0f2bb1c8e9c9190c312746a4b4 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/julia.scm')
-rw-r--r--gnu/packages/julia.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/julia.scm b/gnu/packages/julia.scm
index f6df2817d3..41bbc66dd2 100644
--- a/gnu/packages/julia.scm
+++ b/gnu/packages/julia.scm
@@ -146,6 +146,12 @@
(lambda* (#:key inputs #:allow-other-keys)
(use-modules (ice-9 match))
(substitute* "src/runtime_ccall.cpp"
+ ;; Patch out invocations of '/sbin/ldconfig' to avoid getting
+ ;; error messages about missing '/sbin/ldconfig' on GuixSD.
+ (("popen\\(.*ldconfig.*\\);")
+ "NULL;\n")
+
+ ;; Populate 'sonameMap'.
(("jl_read_sonames.*;")
(string-join
(map (match-lambda
@@ -228,6 +234,12 @@
#t))
(add-before 'check 'disable-broken-tests
(lambda _
+ ;; Adjust expected error messages to match what current libgit2
+ ;; provides.
+ (substitute* "test/libgit2.jl"
+ (("Invalid Content-Type") "invalid Content-Type")
+ (("Failed to resolve path") "failed to resolve path"))
+
(substitute* "test/choosetests.jl"
;; These tests fail, probably because some of the input
;; binaries have been stripped and thus backtraces don't look