summaryrefslogtreecommitdiff
path: root/gnu/packages/jupyter.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-07 22:26:32 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-05-07 22:26:32 +0200
commit5921b80f202880a5848acb9d0533b5b40a432142 (patch)
tree90f8cea760f7238ddda2a337d4fcaed73855b198 /gnu/packages/jupyter.scm
parent6671ea0d03d351462ef5f2bdbdee52a2b28f7067 (diff)
gnu: Add python-jupyter-server-terminals.
* gnu/packages/jupyter.scm (python-jupyter-server-terminals): New variable. Change-Id: I83445e6ac40e21e6e284f1764090f113f56921bf
Diffstat (limited to 'gnu/packages/jupyter.scm')
-rw-r--r--gnu/packages/jupyter.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/jupyter.scm b/gnu/packages/jupyter.scm
index 213dbf627a..2580a1b27b 100644
--- a/gnu/packages/jupyter.scm
+++ b/gnu/packages/jupyter.scm
@@ -575,6 +575,29 @@ JavaScript build steps.")
endpoints—to Jupyter web applications.")
(license license:expat)))
+(define-public python-jupyter-server-terminals
+ (package
+ (name "python-jupyter-server-terminals")
+ (version "0.5.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "jupyter_server_terminals" version))
+ (sha256
+ (base32 "0sajiadhwncrr0inzzkrs7l1xc6jmw9b5zfw1v79l3i2cx8jkq2s"))))
+ (build-system pyproject-build-system)
+ ;; The tests require python-jupyter-server, but python-jupyter-server
+ ;; needs this package.
+ (arguments (list #:tests? #false))
+ (propagated-inputs (list python-terminado))
+ (native-inputs
+ (list python-hatchling))
+ (home-page "https://pypi.org/project/jupyter-server-terminals/")
+ (synopsis "Jupyter Server extension providing terminals")
+ (description
+ "This package provides a Jupyter Server extension providing terminals.")
+ (license license:bsd-3)))
+
(define-public python-jupyterlab-widgets
(package
(name "python-jupyterlab-widgets")