summaryrefslogtreecommitdiff
path: root/gnu/packages/jupyter.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-10-25 15:57:52 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-10-25 16:58:40 +0200
commit1b9a0135fb54076f695178eae9f65a6567745898 (patch)
tree857642a94d828d505adcfb5480c9f58d6b84b281 /gnu/packages/jupyter.scm
parentf1499ff35a3d3942bbb0fbfe9669b10e454f443e (diff)
gnu: Add python-jupyterlite-core.
* gnu/packages/jupyter.scm (python-jupyterlite-core): New variable. Change-Id: I3b015f7bbb45d9575280a5b8c01d67459d6f143e
Diffstat (limited to 'gnu/packages/jupyter.scm')
-rw-r--r--gnu/packages/jupyter.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/jupyter.scm b/gnu/packages/jupyter.scm
index 9337197cb2..7285afdfd0 100644
--- a/gnu/packages/jupyter.scm
+++ b/gnu/packages/jupyter.scm
@@ -410,6 +410,32 @@ endpoints—to Jupyter web applications.")
are interactive HTML widgets for Jupyter notebooks and the IPython kernel.")
(license license:bsd-3)))
+(define-public python-jupyterlite-core
+ (package
+ (name "python-jupyterlite-core")
+ (version "0.1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "jupyterlite_core" version))
+ (sha256
+ (base32 "18ysrqlsh7a31sknfnng419r7wpx9nfj59lxxd6zl1kcj6wazh34"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-doit python-importlib-metadata
+ python-jupyter-core))
+ (native-inputs (list python-ansi2html
+ python-hatchling
+ python-pytest-console-scripts
+ python-pytest-cov
+ python-pytest-xdist
+ python-tornado-6))
+ (home-page "https://github.com/jupyterlite/jupyterlite")
+ (synopsis "Core functionality for building JupyterLite websites")
+ (description "The jupyterlite-core package provides the core functionality
+for building JupyterLite websites, the jupyter-lite CLI, and extension points
+for authoring custom addons.")
+ (license license:bsd-3)))
+
(define-public python-jupyter-server-mathjax
(package
(name "python-jupyter-server-mathjax")