summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorZheng Junjie <873216071@qq.com>2023-07-13 00:43:21 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-08-02 22:27:40 +0800
commit61906ca308d8223e1e9611623ddaa6d22c98f9f6 (patch)
treeba63d8b18b3f3c59eccff74391365a7d0310f3e1 /gnu/packages/kde-frameworks.scm
parentaacb142b645f71f376afdb718c8666efc3ec0e70 (diff)
gnu: kdbusaddons: Update to 5.108.0.
* gnu/packages/kde-frameworks.scm (kdbusaddons): Update to 5.108.0. (kxmlgui) [arguments]: exclude KMAINWINDOW_UNITTEST test for make sure KDBUSADDONS build success. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm37
1 files changed, 19 insertions, 18 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index d36000197a..798ab8ccaa 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -665,7 +665,7 @@ many more.")
(define-public kdbusaddons
(package
(name "kdbusaddons")
- (version "5.98.0")
+ (version "5.108.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -674,7 +674,7 @@ many more.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0fwdmlnci2xn5pi1ywgia3xka3zsh6gl6xpx1gvql7lczk1y490a"))))
+ "1siv9ndk0zr9yq6pwjs248zzsh4kgllfj1294jym80rxcb0z6g9r"))))
(build-system cmake-build-system)
(native-inputs
(list extra-cmake-modules dbus qttools-5))
@@ -683,21 +683,22 @@ many more.")
;; kinit-bootstrap: kinit package which does not depend on kdbusaddons.
(arguments
(list #:phases
- #~(modify-phases %standard-phases
- (add-before 'configure 'patch-source
- (lambda* (#:key inputs #:allow-other-keys)
- ;; look for the kdeinit5 executable in kinit's store directory,
- ;; instead of the current application's directory:
- (substitute* "src/kdeinitinterface.cpp"
- (("<< QCoreApplication::applicationDirPath..")
- (string-append
- "<< QString::fromUtf8(\"/" (dirname (search-input-file inputs
- "bin/kdeinit5")) "\")" )))))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (setenv "DBUS_FATAL_WARNINGS" "0")
- (invoke "dbus-launch" "ctest")))))))
+ #~(modify-phases %standard-phases
+ (add-before 'configure 'patch-source
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; look for the kdeinit5 executable in kinit's store directory,
+ ;; instead of the current application's directory:
+ (substitute* "src/kdeinitinterface.cpp"
+ (("<< QCoreApplication::applicationDirPath..")
+ (string-append
+ "<< QString::fromUtf8(\"/"
+ (dirname (search-input-file inputs "bin/kdeinit5"))
+ "\")" )))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (setenv "DBUS_FATAL_WARNINGS" "0")
+ (invoke "dbus-launch" "ctest")))))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Convenience classes for DBus")
(description "KDBusAddons provides convenience classes on top of QtDBus,
@@ -3259,7 +3260,7 @@ the passwords on KDE work spaces.")
(setenv "HOME" (getcwd))
(setenv "QT_QPA_PLATFORM" "offscreen") ;; These tests fail
(invoke "ctest" "-E"
- "(ktoolbar_unittest|kxmlgui_unittest)")))))))
+ "(ktoolbar_unittest|kmainwindow_unittest|kxmlgui_unittest)")))))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Framework for managing menu and toolbar actions")
(description "KXMLGUI provides a framework for managing menu and toolbar