summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2018-12-23 23:01:55 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2018-12-23 23:42:49 +0100
commit450226ebc1b2611ff62469d314e7ca2973bbf131 (patch)
tree069df0380b16e520ca04739602f690b6e31010ec /gnu/packages/kde-frameworks.scm
parent8f2253af7da1c537b4c11e6b43c8d0a9f026b609 (diff)
gnu: baloo: Fix build.
The substitute for removing a failing test did no longer work since the way the test is included changed in v5.45.0: Formerly the test has listed, now there is a separate statement for this test. * gnu/package/kde-frameworks.scm((baloo)[arguments]<#phases>: Change substitute in phase 'remove-failing-test'.
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index f5a084a7e8..bc28511d3f 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -2003,7 +2003,8 @@ gallons).")
;; This test fails on i686 and aarch64
(lambda _
(substitute* "autotests/unit/file/CMakeLists.txt"
- (("metadatamovertest") ""))
+ (("^\\s*ecm_add_test\\(.* TEST_NAME metadatamovertest .*" line)
+ (string-append "# " line)))
#t))
(replace 'check
(lambda _