summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-24 19:13:46 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-29 19:11:09 +0100
commit7b722e3cba89977c14172ea44738704fcf6b250b (patch)
tree1cb9873a2377a2ae3eb373e8788f0ee52da54822 /gnu/packages/kde-frameworks.scm
parentc1265fcc7090eccef32fdc8d5e38b4f596108e09 (diff)
gnu: extra-cmake-modules: Always install into /lib and not into /lib64.
* gnu/packages/kde-frameworks.scm (extra-cmake-modules)[phases]: New phase fix-lib-path.
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index c67d0c393f..4857cf2354 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -71,6 +71,11 @@
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-lib-path
+ (lambda _
+ ;; Always install into /lib and not into /lib64.
+ (substitute* "kde-modules/KDEInstallDirs.cmake"
+ (("\"lib64\"") "\"lib\""))))
;; install and check phase are swapped to prevent install from failing
;; after testsuire has run
(add-after 'install 'check-post-install